summaryrefslogtreecommitdiff
path: root/dev-python/dask
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest2
-rw-r--r--dev-python/dask/dask-2023.1.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index d545681c5334..7659a0340b7b 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,3 +1,5 @@
DIST dask-2022.12.1.gh.tar.gz 8233697 BLAKE2B 90caeb7a8a9abc03b035c787ae2f26d5dacbd8da9314b65deb7c38e1990a7d3067b4066c8f2bbb6d8179d03af471374df28e511f000097cb7b031e692e72ccd9 SHA512 1945f5737de55c559aff14c67efeee00afef18ff5dbdc07aa79affd89eb45a0808078bbc7ce24c904168e7c7a74a678a8dc90ed129593777dd25598cb45372b6
+DIST dask-2023.1.0.gh.tar.gz 8234373 BLAKE2B 39f4d6336604a66ac769732a36c718b983d2fc37a59276c4140e35354c5c469b5edbff2333ae0b52f3f1462b85ae5c11fc994a99a79330394fff0d7ead14035f SHA512 99650fd2d3805e557ee91bd578e8e4af7f12cc78bbaf72f406d13ff7805591ca0f307d78bb68fdb320dab82da23def01244708e31a87d1a8b5b18dcec8a048fb
EBUILD dask-2022.12.1-r1.ebuild 1780 BLAKE2B 08640632cc03a699e1824655b9da4337bcb190c82fb7c38448e717e208d4de0bcba0d841de0e5986e5785c3008ba1cde4b84d6869e84823f949effae67ef8896 SHA512 ab09ab6bd8fd5eef7a0cc6728938fac131ff85a0fd0b5d0702efeeb67f1ec851827f0a5acf9cb3c45d5c22928ec6770824c4fc09ee79b85bfe961fcc2cac680d
+EBUILD dask-2023.1.0.ebuild 1781 BLAKE2B 3376599fb69f99d5e3088632adf6ae3b9ea08546af497850a2ea0eca99e08198163b07ba762d1316e6e5d7d2fbd06319c0b628ded12ff9cbd88b5f6e9049a14c SHA512 227eaf57c69c39abaa64c8ae1a057e8f78b4cd89ea2f1a48cf73e48a378ca16a9a14f23ffa9d90a2a1d51a67e7d050039f10534403ca36161f5c294a4feae2f0
MISC metadata.xml 724 BLAKE2B 9af7553cec2b66228a21f146372d86b8d620048d68f94c1fd09006c8ee7ddaa4e212c2a359b937a5ee37ac23df01e10af0796e8b4cf952237cb4c73a2dff7ca0 SHA512 89b83402c13b06f7adf10cd1cc08b96b90dbc2ca3b5c0c6c422b6e2394e03fd51346306479557c11fcfdbd4a81a574890f2367228ea38531b5f05c02a30b8dcb
diff --git a/dev-python/dask/dask-2023.1.0.ebuild b/dev-python/dask/dask-2023.1.0.ebuild
new file mode 100644
index 000000000000..ebb7eda40220
--- /dev/null
+++ b/dev-python/dask/dask-2023.1.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}