summaryrefslogtreecommitdiff
path: root/dev-python/dbus-python/dbus-python-1.2.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbus-python/dbus-python-1.2.16.ebuild')
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.16.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.2.16.ebuild b/dev-python/dbus-python/dbus-python-1.2.16.ebuild
index d7512b4dc8f8..e07d2500f718 100644
--- a/dev-python/dbus-python/dbus-python-1.2.16.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.16.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
PYTHON_REQ_USE="threads(+)"
inherit autotools python-r1
@@ -33,6 +33,8 @@ BDEPEND="
dev-python/tappy[${PYTHON_USEDEP}] )
"
+PATCHES=( "${FILESDIR}/${P}-py39.patch" )
+
python_check_deps() {
has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
}