summaryrefslogtreecommitdiff
path: root/dev-python/dbus-python/dbus-python-1.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbus-python/dbus-python-1.3.2.ebuild')
-rw-r--r--dev-python/dbus-python/dbus-python-1.3.2.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.3.2.ebuild b/dev-python/dbus-python/dbus-python-1.3.2.ebuild
index 5065a91958cf..1a653ddb7cd5 100644
--- a/dev-python/dbus-python/dbus-python-1.3.2.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.3.2.ebuild
@@ -3,22 +3,23 @@
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
inherit autotools python-r1
DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings/ https://dbus.freedesktop.org/doc/dbus-python/"
+HOMEPAGE="
+ https://www.freedesktop.org/wiki/Software/DBusBindings/
+ https://dbus.freedesktop.org/doc/dbus-python/
+"
SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
IUSE="doc examples test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
RESTRICT="!test? ( test )"
RDEPEND="${PYTHON_DEPS}
@@ -28,12 +29,16 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( $(python_gen_any_dep '
+ doc? (
+ $(python_gen_any_dep '
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
- ') )
- test? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/tappy[${PYTHON_USEDEP}] )
+ ')
+ )
+ test? (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/tappy[${PYTHON_USEDEP}]
+ )
"
python_check_deps() {