summaryrefslogtreecommitdiff
path: root/dev-python/dill/dill-0.3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dill/dill-0.3.1.1.ebuild')
-rw-r--r--dev-python/dill/dill-0.3.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/dill/dill-0.3.1.1.ebuild b/dev-python/dill/dill-0.3.1.1.ebuild
new file mode 100644
index 000000000000..2df94b7bb42e
--- /dev/null
+++ b/dev-python/dill/dill-0.3.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}