summaryrefslogtreecommitdiff
path: root/dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild')
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild
new file mode 100644
index 000000000000..2f4d32066ff1
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/decorator-4.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest