summaryrefslogtreecommitdiff
path: root/dev-python/duecredit/duecredit-0.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/duecredit/duecredit-0.9.2.ebuild')
-rw-r--r--dev-python/duecredit/duecredit-0.9.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/duecredit/duecredit-0.9.2.ebuild b/dev-python/duecredit/duecredit-0.9.2.ebuild
new file mode 100644
index 000000000000..695d621282e5
--- /dev/null
+++ b/dev-python/duecredit/duecredit-0.9.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Publications (and donations) tracer"
+HOMEPAGE="https://github.com/duecredit/duecredit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/citeproc-py-0.4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # internet?
+ 'duecredit/tests/test_api.py::test_noincorrect_import_if_no_lxml_numpy[kwargs1-env2]'
+)