summaryrefslogtreecommitdiff
path: root/dev-python/e4u
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/e4u')
-rw-r--r--dev-python/e4u/Manifest5
-rw-r--r--dev-python/e4u/e4u-0.1_rc4.ebuild39
-rw-r--r--dev-python/e4u/files/change-emoji4unicode-url.patch33
-rw-r--r--dev-python/e4u/files/initialize-e4u-tests.patch11
-rw-r--r--dev-python/e4u/metadata.xml21
5 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/e4u/Manifest b/dev-python/e4u/Manifest
new file mode 100644
index 000000000000..a618bd5ac4da
--- /dev/null
+++ b/dev-python/e4u/Manifest
@@ -0,0 +1,5 @@
+AUX change-emoji4unicode-url.patch 1513 BLAKE2B 352f73e293cbec9230e74fec1ae9884edf3b07ffe05968d32b619ff84160a922f358c9f2d59e40443fa43f2dc13df6e51a961c413b028123f6010228329299e6 SHA512 65cd47b7ad291229b4a68aee598ccca03ebfbfa3c417f02f38711321a4c594f4633745a758fbb2e3a4486064253f79ce45d11e5c394e14665b85afbc9732b96a
+AUX initialize-e4u-tests.patch 268 BLAKE2B 30fc61d356c763aab4c5152cbeb00ac8b925a4ac043da8d66f997969c9ea0ab6e2cd6004cc1415006e1488af0ef52f871b6351ae8115da9ac6fa4514808a2513 SHA512 d4973560dab89e59810f81e4604689e6e40043c7027ae58d0e3b54d8dcb221a1a0aa307d6cc0acef8a497c87b33e0d09938a401990f05019858b0289f1ac2198
+DIST e4u-0.1rc4.tar.gz 50266 BLAKE2B 2cb878837ca34c7839e026b1f742ec23d9ee2c046406084ef10fca4c565b4661237ddf9f76620abc8db968dd5c521be4219752ff8ec4017326b57dc5de9b4ef0 SHA512 8ca0a0a160ddd1425be4f8a941d9767edac89edfaf5f5f14af840f3460ad91344186f8111711e0fb7af212d15af1f766d592e887511f820770b9f66818896a1d
+EBUILD e4u-0.1_rc4.ebuild 862 BLAKE2B 545e5c3ea0f8765275d776b12c56215fac9b8146509724a07b58cf1bf77d29a21ec32cc8a2abd9a1ee98035d741c86a8b73740e5875b7cbec0c9f5d8005916d9 SHA512 4b577078b7f1c9db5ff143776f27232df7322e30bf678eb85ad4ca65201be7573fddad9613f5dbc342e5f03b37e3fc3d7c538fe246c6b1eda51f1b44713da70c
+MISC metadata.xml 728 BLAKE2B df21a956ca12a239654af8886880833482950fef29e5bce8532229a218cf6ff6cf442e66e8c12dd739eedb21696f288a4e714d94d4a90f1f02bb57e20153b90a SHA512 0c98742721f00b7ce92f660aa4d5760b1e8b22436577df6aae110f5e521e2be5e019cb958c17ab22f31c7c099af4d5328f8b612325fe538131c18f90d453fdd5
diff --git a/dev-python/e4u/e4u-0.1_rc4.ebuild b/dev-python/e4u/e4u-0.1_rc4.ebuild
new file mode 100644
index 000000000000..93b757abd30c
--- /dev/null
+++ b/dev-python/e4u/e4u-0.1_rc4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PV="${PV/_/}"
+
+DESCRIPTION="A library for handling unicode emoji and carrier's emoji"
+HOMEPAGE="https://github.com/lambdalisue/e4u"
+SRC_URI="https://github.com/lambdalisue/e4u/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PATCHES=( "${FILESDIR}/change-emoji4unicode-url.patch" "${FILESDIR}/initialize-e4u-tests.patch" )
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ insinto /usr/share/e4u
+ doins e4u/data/emoji4unicode.xml
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/e4u/files/change-emoji4unicode-url.patch b/dev-python/e4u/files/change-emoji4unicode-url.patch
new file mode 100644
index 000000000000..d356e7d68cae
--- /dev/null
+++ b/dev-python/e4u/files/change-emoji4unicode-url.patch
@@ -0,0 +1,33 @@
+--- a/e4u/__init__.py 2013-06-13 09:14:06.000000000 +0200
++++ b/e4u/__init__.py 2018-05-18 15:35:49.000000000 +0200
+@@ -11,15 +11,15 @@
+
+ _loader = None
+
+-def load(filename=None,
+- url=r"http://emoji4unicode.googlecode.com/svn/trunk/data/emoji4unicode.xml",
++def load(filename=r"/usr/share/e4u/emoji4unicode.xml",
++ url=None,
+ loader_class=None):
+ u"""load google's `emoji4unicode` project's xml file. must call this method first to use `e4u` library. this method never work twice if you want to reload, use `e4u.reload()` insted."""
+ if not has_loaded():
+ reload(filename, url, loader_class)
+
+-def reload(filename=None,
+- url=r"http://emoji4unicode.googlecode.com/svn/trunk/data/emoji4unicode.xml",
++def reload(filename=r"/usr/share/e4u/emoji4unicode.xml",
++ url=None,
+ loader_class=None):
+ u"""reload google's `emoji4unicode` project's xml file. must call this method first to use `e4u` library."""
+ if loader_class is None:
+--- a/e4u/loader.py 2013-06-13 09:14:06.000000000 +0200
++++ b/e4u/loader.py 2018-05-18 15:36:01.000000000 +0200
+@@ -32,7 +32,7 @@
+ self._translate_dictionaries = create_translate_dictionaries(self.symbols)
+
+
+- def load(self, filename=None, url=r"http://emoji4unicode.googlecode.com/svn/trunk/data/emoji4unicode.xml"):
++ def load(self, filename=r"/usr/share/e4u/emoji4unicode.xml", url=None):
+ if filename:
+ xml = open(filename, 'r').read()
+ else:
diff --git a/dev-python/e4u/files/initialize-e4u-tests.patch b/dev-python/e4u/files/initialize-e4u-tests.patch
new file mode 100644
index 000000000000..4d9a25d5de99
--- /dev/null
+++ b/dev-python/e4u/files/initialize-e4u-tests.patch
@@ -0,0 +1,11 @@
+--- a/test/test.py 2013-06-13 09:14:06.000000000 +0200
++++ b/test/test.py 2018-05-16 13:40:22.000000000 +0200
+@@ -7,6 +7,8 @@
+ import unittest
+ import e4u
+
++e4u.load(filename=r"./e4u/data/emoji4unicode.xml")
++
+ DISPLAY_INFO = False
+
+ class TestCaseAbstract(object):
diff --git a/dev-python/e4u/metadata.xml b/dev-python/e4u/metadata.xml
new file mode 100644
index 000000000000..5e7524088529
--- /dev/null
+++ b/dev-python/e4u/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/lambdalisue/e4u/issues</bugs-to>
+ <remote-id type="github">lambdalisue/e4u</remote-id>
+ </upstream>
+ <longdescription>
+ A library for handling unicode emoji and carrier's emoji.
+ The main feature is conversion unicode emoji to carrier's emoji
+ and conversion carrier's emoji to unicode emoji.
+ </longdescription>
+</pkgmetadata>