summaryrefslogtreecommitdiff
path: root/dev-python/ecdsa/ecdsa-0.14.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ecdsa/ecdsa-0.14.1-r2.ebuild')
-rw-r--r--dev-python/ecdsa/ecdsa-0.14.1-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ecdsa/ecdsa-0.14.1-r2.ebuild b/dev-python/ecdsa/ecdsa-0.14.1-r2.ebuild
new file mode 100644
index 000000000000..bdfa5f183100
--- /dev/null
+++ b/dev-python/ecdsa/ecdsa-0.14.1-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ECDSA cryptographic signature library in pure Python"
+HOMEPAGE="https://github.com/warner/python-ecdsa"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint"
+IUSE="test"
+
+BDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/idna[${PYTHON_USEDEP}]' -2)
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
+ )"
+
+distutils_enable_tests pytest