summaryrefslogtreecommitdiff
path: root/dev-python/entrypoint2/entrypoint2-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/entrypoint2/entrypoint2-1.0.ebuild')
-rw-r--r--dev-python/entrypoint2/entrypoint2-1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/entrypoint2/entrypoint2-1.0.ebuild b/dev-python/entrypoint2/entrypoint2-1.0.ebuild
new file mode 100644
index 000000000000..9b2ed1b03eef
--- /dev/null
+++ b/dev-python/entrypoint2/entrypoint2-1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Easy to use command-line interface for python modules"
+HOMEPAGE="https://github.com/ponty/entrypoint2"
+SRC_URI="https://github.com/ponty/entrypoint2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest