summaryrefslogtreecommitdiff
path: root/dev-python/entrypoints/entrypoints-0.3-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/entrypoints/entrypoints-0.3-r3.ebuild')
-rw-r--r--dev-python/entrypoints/entrypoints-0.3-r3.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/entrypoints/entrypoints-0.3-r3.ebuild b/dev-python/entrypoints/entrypoints-0.3-r3.ebuild
new file mode 100644
index 000000000000..1f220ff7c478
--- /dev/null
+++ b/dev-python/entrypoints/entrypoints-0.3-r3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Discover and load entry points from installed packages"
+HOMEPAGE="https://github.com/takluyver/entrypoints"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest