summaryrefslogtreecommitdiff
path: root/dev-python/exam
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/exam')
-rw-r--r--dev-python/exam/Manifest3
-rw-r--r--dev-python/exam/exam-0.10.6.ebuild22
-rw-r--r--dev-python/exam/metadata.xml28
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/exam/Manifest b/dev-python/exam/Manifest
new file mode 100644
index 000000000000..104226a6dbe2
--- /dev/null
+++ b/dev-python/exam/Manifest
@@ -0,0 +1,3 @@
+DIST exam-0.10.6.tar.gz 15028 BLAKE2B 6d2a888b9adf14665e8f009bae7b2c724dcb60fe19efa98a189988a73a0cb5933179407c754ed1c19b24694080b6df31838768f694460fabd9196e58e8b4c94d SHA512 1cc082b4fb9a7270ea81750ee3f34400f3f6eac65dd1488af333a43d0623bf8f9176b73e2948c324bb9c0062296284bae66fe215263456baf9db378676c8a4f0
+EBUILD exam-0.10.6.ebuild 423 BLAKE2B 6d638a563eb9ff3d11d0c259dd0865813dee2350da05260c174d3406b17aaf8d7db1d3ddee4f770677745a90a4ac33754d3722d997cc37e0523e7ee5b83364c9 SHA512 2ea40e7c3cd58f21df3c39add900cc69160bd33789d1ddf7deeb8f3488223e7b22d9b18cc60993f04217e1a68d1e572d35787dc3a39d7831a9cda59a58b43bae
+MISC metadata.xml 1685 BLAKE2B 51e5e8f94272ea0318f683f1868e3d2519f492d4b3a4870990ff574fa08dd094ea976e56b8cede7e554ebc8471685c6efaf13355735c021e881c96200d3412d0 SHA512 48974f1aa263535521d2691b715f4500f512ca903fd325339a7614cfe25ca836af17aca742e2d4939752c8acb741380a4e5ce6ae3fad2b3babbad85f8e06e48e
diff --git a/dev-python/exam/exam-0.10.6.ebuild b/dev-python/exam/exam-0.10.6.ebuild
new file mode 100644
index 000000000000..3936796fb019
--- /dev/null
+++ b/dev-python/exam/exam-0.10.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers for better testing"
+HOMEPAGE="https://github.com/fluxx/exam"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
diff --git a/dev-python/exam/metadata.xml b/dev-python/exam/metadata.xml
new file mode 100644
index 000000000000..e782094b1d21
--- /dev/null
+++ b/dev-python/exam/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fluxx/exam</remote-id>
+ </upstream>
+ <longdescription lang="en">
+Exam is a Python toolkit for writing better tests. It aims to remove a lot of the boiler plate testing code one often writes, while still following Python conventions and adhering to the unit testing interface.
+
+Aside from the obvious "does the code work?", writings tests has many additional goals and benefits:
+
+ If written semantically, reading tests can help demonstrate how the code is supposed to work to other developers.
+ If quick running, tests provide feedback during development that your changes are working or not having an adverse side effects.
+ If they're easy to write correctly, developers will write more tests and they will be of a higher quality.
+
+Unfortunately, the common pattern for writing Python unit tests tends to not offer any of these advantages. Often times results in inefficient and unnecessarily obtuse testing code. Additionally, common uses of the mock library can often result in repetitive boiler-plate code or inefficiency during test runs.
+
+exam aims to improve the state of Python test writing by providing a toolkit of useful functionality to make writing quick, correct and useful tests and as painless as possible.
+ </longdescription>
+</pkgmetadata>