summaryrefslogtreecommitdiff
path: root/dev-python/flask-bootstrap
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-bootstrap')
-rw-r--r--dev-python/flask-bootstrap/Manifest7
-rw-r--r--dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild57
-rw-r--r--dev-python/flask-bootstrap/flask-bootstrap-3.3.7.0.ebuild57
-rw-r--r--dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild58
-rw-r--r--dev-python/flask-bootstrap/metadata.xml13
5 files changed, 192 insertions, 0 deletions
diff --git a/dev-python/flask-bootstrap/Manifest b/dev-python/flask-bootstrap/Manifest
new file mode 100644
index 000000000000..c52cb8808ea2
--- /dev/null
+++ b/dev-python/flask-bootstrap/Manifest
@@ -0,0 +1,7 @@
+DIST flask-bootstrap-3.3.6.0.tar.gz 489779 BLAKE2B ad35fbdbb8ce9700cf23759c3ebff11952ce5ba5c25628877fb7e7ec2032ac2e885579d8d9ffdd639abc842d7b7f06e40f695ab933aabbb09a2da300027ee787 SHA512 4cf08a6fd75185fdf5c89783cf8610d74835bf9dc07bd83b36819147bd40cf0e10d20f563a5fc5b8e799e2b87f1e80ad896c76930ca1bc72f74a94818ac708c8
+DIST flask-bootstrap-3.3.7.0.tar.gz 490438 BLAKE2B a254525eaa2a71abdd3d2a9964e79c734c59e73bc5fd7c3084c8ef4c74d07585b1af4421ea3ea5905a017708387c10fdcd76220be8da946f670f1fcc4020387b SHA512 0c7950d633d88f2e71eab444760229efde324b5169bc774215db4a5cd816d4b8eee8b5d55a68921330b2018d4ae57aafefa6e66cefa0ee822260103cf42143e6
+DIST flask-bootstrap-3.3.7.1.tar.gz 490821 BLAKE2B 48773fa1632a9b34284af90924d0d7c6bbe06e43c30b09e72747072d4cdead88a08a1d95a661548709cc46cb9d9c9c017835cd6537ec1a23993fe79cfef31662 SHA512 010c71f69a95cb51afb449d1b43cb345ad23815ea89b368281f721a2af13cf2c143d67b586114898450d8e7fec413f45ff042cfca3dc1183cb0f50566e39fdc3
+EBUILD flask-bootstrap-3.3.6.0.ebuild 1517 BLAKE2B 5d52494da100f84f03c5312c2decf6be865f8d7aa72af60b98fd64958cb33ba8319accfccb9a37fec1ac5e224d629775af84d9ecf070c5c1523c47228b0d0c40 SHA512 aec7901141da7394f73ae79ea92a42fd3af6789f469ae197901c5d311e78e0eeab1230e6863f0614975759749310ddec8e0e78bc0fa67fbe30c2b4f791d8146a
+EBUILD flask-bootstrap-3.3.7.0.ebuild 1517 BLAKE2B 5d52494da100f84f03c5312c2decf6be865f8d7aa72af60b98fd64958cb33ba8319accfccb9a37fec1ac5e224d629775af84d9ecf070c5c1523c47228b0d0c40 SHA512 aec7901141da7394f73ae79ea92a42fd3af6789f469ae197901c5d311e78e0eeab1230e6863f0614975759749310ddec8e0e78bc0fa67fbe30c2b4f791d8146a
+EBUILD flask-bootstrap-3.3.7.1.ebuild 1524 BLAKE2B fb60b113a9cb414ac91f692d158ecdfef00029300d245111a4c8e5dd5c45ff23f9188fdce70f7237730253684b874fa67338c1166b18017545d3b6eb8f3f5832 SHA512 fd59a78df6f77c557fc93c2a09d23012dd37bd58c1d0dc607ac86ae8717905844a09fd376cd2342d962dedfac58955a1f8c4912e576928fa7ef8f3d523075a75
+MISC metadata.xml 449 BLAKE2B 9e9297b48e6a43c171d18f6d6b03767499c9edd2be418bd9493048906ad261c9b715f4d86cbebc478a76cd432600b9bebfa006926c65c9c029551ea24556194c SHA512 d0a640007c8cdfb9c950c2de71fc4ea97d8d2a2499bce05bc0e7ac0b4983d9ca9d8782f39129f8f664549f531be35ab471023e9f498498ff8aa821622d39332b
diff --git a/dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild b/dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild
new file mode 100644
index 000000000000..23574c4628d7
--- /dev/null
+++ b/dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="An extension that includes Bootstrap in your project, without boilerplate code"
+HOMEPAGE="https://pythonhosted.org/Flask-Bootstrap/"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/flask-bootstrap/pull/134
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flask-appconfig[${PYTHON_USEDEP}]
+ dev-python/flask-debug[${PYTHON_USEDEP}]
+ dev-python/flask-nav[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Skip one test which requires network access
+ py.test -k "not test_versions_match" || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.0.ebuild b/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.0.ebuild
new file mode 100644
index 000000000000..23574c4628d7
--- /dev/null
+++ b/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="An extension that includes Bootstrap in your project, without boilerplate code"
+HOMEPAGE="https://pythonhosted.org/Flask-Bootstrap/"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/flask-bootstrap/pull/134
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flask-appconfig[${PYTHON_USEDEP}]
+ dev-python/flask-debug[${PYTHON_USEDEP}]
+ dev-python/flask-nav[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Skip one test which requires network access
+ py.test -k "not test_versions_match" || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild b/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild
new file mode 100644
index 000000000000..939d06eb18c0
--- /dev/null
+++ b/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="An extension that includes Bootstrap in your project, without boilerplate code"
+HOMEPAGE="https://pythonhosted.org/Flask-Bootstrap/"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/flask-bootstrap/pull/134
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flask-appconfig[${PYTHON_USEDEP}]
+ dev-python/flask-debug[${PYTHON_USEDEP}]
+ dev-python/flask-nav[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ doc? (
+ dev-python/alabaster[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # Skip one test which requires network access
+ py.test -k "not test_versions_match" || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/flask-bootstrap/metadata.xml b/dev-python/flask-bootstrap/metadata.xml
new file mode 100644
index 000000000000..b3dc8b3897d7
--- /dev/null
+++ b/dev-python/flask-bootstrap/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">flask-bootstrap</remote-id>
+ <remote-id type="github">mbr/flask-bootstrap</remote-id>
+ <bugs-to>https://github.com/mbr/flask-bootstrap/issues</bugs-to>
+ </upstream>
+</pkgmetadata>