summaryrefslogtreecommitdiff
path: root/dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild')
-rw-r--r--dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild b/dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild
deleted file mode 100644
index 22d2f703dbb6..000000000000
--- a/dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_COMMIT="510ad833106134711868653fb597bf75ea8ac34f"
-
-DESCRIPTION="Pagination support for flask"
-HOMEPAGE="https://flask-paginate.readthedocs.io"
-# https://github.com/lixxu/flask-paginate/issues/68
-SRC_URI="https://github.com/lixxu/flask-paginate/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}/${PN}-${MY_COMMIT}"
-
-python_test() {
- pytest -vv tests/tests.py || die "tests failed with ${EPYTHON}"
-}