summaryrefslogtreecommitdiff
path: root/dev-python/flask-paginate/flask-paginate-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-paginate/flask-paginate-0.7.0.ebuild')
-rw-r--r--dev-python/flask-paginate/flask-paginate-0.7.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/flask-paginate-0.7.0.ebuild b/dev-python/flask-paginate/flask-paginate-0.7.0.ebuild
new file mode 100644
index 000000000000..8435e67f09fc
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-0.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests/tests.py || die "tests failed with ${EPYTHON}"
+}