summaryrefslogtreecommitdiff
path: root/dev-python/flask-restful
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-restful')
-rw-r--r--dev-python/flask-restful/Manifest5
-rw-r--r--dev-python/flask-restful/files/flask-restful-0.3.8-werkzeug.patch41
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.8.ebuild45
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.9.ebuild2
4 files changed, 2 insertions, 91 deletions
diff --git a/dev-python/flask-restful/Manifest b/dev-python/flask-restful/Manifest
index 33af11dfa902..1fab85c0b2d9 100644
--- a/dev-python/flask-restful/Manifest
+++ b/dev-python/flask-restful/Manifest
@@ -1,6 +1,3 @@
-AUX flask-restful-0.3.8-werkzeug.patch 1517 BLAKE2B fa895690ca771f1b4431c62baec0577554fca082418c2421eb8012be2e234699eab54f2690d237dbd490f536eae5fe0fdfd8fedad16fc60bd92351f66c93a7a4 SHA512 96db20a0850f37ebb90fad0964448783c3af8b9b8128709fc52d509f9b1edad72455330a09f81b4b766eea7b88f3b79fb01e112f1684be7776a8b3a78ab90a19
-DIST flask-restful-0.3.8.tar.gz 114588 BLAKE2B a18eac613300102bb5a5ca78cea1e6f81f3de21d8bd2e6c72f2f1a559e8b4228175cc7d372b68f131267cd8bc759e354e5782e527d1e992579210348cd2b78dd SHA512 15172114fcedc2f4286cf5f583d95e42c8c8ce6553f9a44e57124f2b1417bf9f094dcb5154a6933ebebc8022f39d4d7969d29d38576111f9d5b45f630b36a66c
DIST flask-restful-0.3.9.gh.tar.gz 118195 BLAKE2B a4f18c3faf06a7c9b628657aafbab4b9492793d9a61ab60a3e4d8112e0fb5e120cff2f2dae87915e44915838572ae0ca1737025ad5f906c2a953afc4b1f49c6f SHA512 34bea8ed6e9de3ad1c2ca63e7af67ed2a175f84c433b08ff643f91d88feda0e3c1c3967deb2fe5ad308b05f373b10c08245edf65ed97a7c5a3683aa900e9edf2
-EBUILD flask-restful-0.3.8.ebuild 1006 BLAKE2B 952156256c65bfe2b4962d0df8df914e27026a92ab1a178a760a9738e59885e1fadc531883ec29f36ff88a552f7053345b0997a9fe8073c69ae0b6b4c9eb46e0 SHA512 bcbad3a388eab456d78f6ff3ea985a8c1009cf07db5ea9376c49b751a943dbac248ac4a6f151b8a5838d5ca282e7a9012475d3b3951a55bdd8c05a08e53519dc
-EBUILD flask-restful-0.3.9.ebuild 952 BLAKE2B bf8b1f6c96677f443e2bd5499d3505ff55bc7d2d503702b866b18cbf3ea844dcc09e7f1b018052eebcce1b88f09bb076c2a5353fff2ada018a6ebe8486dcbff1 SHA512 a49e0792b560799e6a719d63403095c5ed82563a4ea1316382cbf3f6a61dc3be7398c5b57ca04b5c09a743ab4c7b82712000532d6ac4be3965abc55472dccdb2
+EBUILD flask-restful-0.3.9.ebuild 950 BLAKE2B f010b4547f34823e4c71135dea52185a39b720dda2178d025de5dc387a459aef1b1f59906c52bdd6f000c8afc176ef4a45530ec1bb033fb8cabb8b5a198afb2f SHA512 0967efc60209aaf8af1b9bff043cdae34a8b63ae24bda3650a16ab935f2e0d32093d494d428d9aa5653bd3b6962b5bc9a2155e7864c6f6c16d7b48bb556f78ea
MISC metadata.xml 407 BLAKE2B 32075e72b358faf256d1f2b0a650eb7b1d966dcb4376a4394933545b0b96d77d633bdcd8cdc6db044c825fdc237b9b4674d38d3d90027f9cb758325121dcba6d SHA512 2b7f74ec3648a92e7740b22a8ee5f367d61553d37fbc854a90cf2774a383e1fdc3382217c7811d21f8a0a98dd363ebefd873a8a8286cbb8e0f781382584ddda5
diff --git a/dev-python/flask-restful/files/flask-restful-0.3.8-werkzeug.patch b/dev-python/flask-restful/files/flask-restful-0.3.8-werkzeug.patch
deleted file mode 100644
index 32b0b7b2b460..000000000000
--- a/dev-python/flask-restful/files/flask-restful-0.3.8-werkzeug.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 73376a488907af3042b52678ac4c23f8a8911e5b Mon Sep 17 00:00:00 2001
-From: Anthony Sottile <asottile@umich.edu>
-Date: Fri, 7 Feb 2020 11:06:15 -0800
-Subject: [PATCH] Fix testsuite for werkzeug 1.x (#862)
-
----
- tests/test_api.py | 4 +++-
- tests/test_reqparse.py | 4 ++--
- 2 files changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/tests/test_api.py b/tests/test_api.py
-index f7f8e661..6795d362 100644
---- a/tests/test_api.py
-+++ b/tests/test_api.py
-@@ -445,7 +445,9 @@ def test_handle_non_api_error(self):
-
- resp = app.get("/foo")
- self.assertEquals(resp.status_code, 404)
-- self.assertEquals('text/html', resp.headers['Content-Type'])
-+ # in newer versions of werkzeug this is `text/html; charset=utf8`
-+ content_type, _, _ = resp.headers['Content-Type'].partition(';')
-+ self.assertEquals('text/html', content_type)
-
- def test_non_api_error_404_catchall(self):
- app = Flask(__name__)
-diff --git a/tests/test_reqparse.py b/tests/test_reqparse.py
-index 2f1fbedf..9776f17c 100644
---- a/tests/test_reqparse.py
-+++ b/tests/test_reqparse.py
-@@ -2,9 +2,9 @@
- import unittest
- from mock import Mock, patch
- from flask import Flask
--from werkzeug import exceptions, MultiDict
-+from werkzeug import exceptions
- from werkzeug.wrappers import Request
--from werkzeug.datastructures import FileStorage
-+from werkzeug.datastructures import FileStorage, MultiDict
- from flask_restful.reqparse import Argument, RequestParser, Namespace
- import six
- import decimal
diff --git a/dev-python/flask-restful/flask-restful-0.3.8.ebuild b/dev-python/flask-restful/flask-restful-0.3.8.ebuild
deleted file mode 100644
index eea5a35b47ce..000000000000
--- a/dev-python/flask-restful/flask-restful-0.3.8.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple framework for creating REST APIs"
-HOMEPAGE="
- https://flask-restful.readthedocs.io/en/latest/
- https://github.com/flask-restful/flask-restful/"
-SRC_URI="https://github.com/flask-restful/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
- >=dev-python/flask-0.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/flask-restful-0.3.8-werkzeug.patch
-)
-
-distutils_enable_sphinx docs
-distutils_enable_tests nose
-
-python_install_all() {
- use examples && dodoc -r examples
- local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-restful/flask-restful-0.3.9.ebuild b/dev-python/flask-restful/flask-restful-0.3.9.ebuild
index 858cb0ca86fc..ced9457b8003 100644
--- a/dev-python/flask-restful/flask-restful-0.3.9.ebuild
+++ b/dev-python/flask-restful/flask-restful-0.3.9.ebuild
@@ -17,7 +17,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="examples"
RDEPEND="