summaryrefslogtreecommitdiff
path: root/dev-python/fuse-python/fuse-python-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fuse-python/fuse-python-1.0.0.ebuild')
-rw-r--r--dev-python/fuse-python/fuse-python-1.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/fuse-python/fuse-python-1.0.0.ebuild b/dev-python/fuse-python/fuse-python-1.0.0.ebuild
new file mode 100644
index 000000000000..2a22b71a21e0
--- /dev/null
+++ b/dev-python/fuse-python/fuse-python-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python FUSE bindings"
+HOMEPAGE="https://github.com/libfuse/python-fuse"
+SRC_URI="https://github.com/libfuse/python-fuse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-fs/fuse:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/python-fuse-${PV}"