summaryrefslogtreecommitdiff
path: root/dev-python/futurist/futurist-0.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/futurist/futurist-0.13.0.ebuild')
-rw-r--r--dev-python/futurist/futurist-0.13.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/futurist/futurist-0.13.0.ebuild b/dev-python/futurist/futurist-0.13.0.ebuild
new file mode 100644
index 000000000000..3c94fc81a197
--- /dev/null
+++ b/dev-python/futurist/futurist-0.13.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful additions to futures, from the future"
+HOMEPAGE="https://pypi.python.org/pypi/futurist http://docs.openstack.org/developer/futurist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/contextlib2-0.4.0[${PYTHON_USEDEP}]"