summaryrefslogtreecommitdiff
path: root/dev-python/ghp-import/ghp-import-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ghp-import/ghp-import-2.1.0.ebuild')
-rw-r--r--dev-python/ghp-import/ghp-import-2.1.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/ghp-import/ghp-import-2.1.0.ebuild b/dev-python/ghp-import/ghp-import-2.1.0.ebuild
new file mode 100644
index 000000000000..75edd4b67f0b
--- /dev/null
+++ b/dev-python/ghp-import/ghp-import-2.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy your docs directly to the gh-pages branch"
+HOMEPAGE="https://github.com/c-w/ghp-import"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+"