summaryrefslogtreecommitdiff
path: root/dev-python/glance_store
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/glance_store')
-rw-r--r--dev-python/glance_store/Manifest4
-rw-r--r--dev-python/glance_store/glance_store-2.3.0.ebuild47
-rw-r--r--dev-python/glance_store/metadata.xml1
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/glance_store/Manifest b/dev-python/glance_store/Manifest
index d42cacfde751..f06bfd86cf18 100644
--- a/dev-python/glance_store/Manifest
+++ b/dev-python/glance_store/Manifest
@@ -1,3 +1,5 @@
DIST glance_store-1.0.1.tar.gz 185244 BLAKE2B 4841bf9db07df06fe4f0dedc9f06e6aa768118aa363946b3145c90f7d58f452c3b1f419bd3545681161481d88566922f8c3f4eb0612c77a0679729fc460d6169 SHA512 77144f41996e8fcc7b5ec3e4246305e6887082a8f62a84c73d0b546c9f635e8f43b95e45a5e3303e504c01ed3608de6358398eeffee226f640035df2f792dc8d
+DIST glance_store-2.3.0.tar.gz 212933 BLAKE2B 69f54fbb44de0e6e9608e38cf0b43ee6fb7df7758d19b6dee6f15fb00a25ce885610ef9c779d2138c08f5d3a28760121ef66edade0b23619685d5f985433247f SHA512 59499c1fa8b596faba0918219b76e5e7d51f6c7e94d14b99f28b2a9f87b456e638bd42fe33124ae9507043a975db6e5b5762e5979258db35b772f41a08d59be6
EBUILD glance_store-1.0.1.ebuild 1650 BLAKE2B e1fa2f9adb22fd6f1ebf87fcede37ef8f88088348cb740bc21b665fd8fda0de1a4d8b9c22bdc3f264c27b0f077aed2f9c784d37f3ff77a85821fb0fe2ee5b329 SHA512 9976022de10c8f91491e61ec4d3ed3658e58d8ed53b988afab7ebf8efcd8cea1b2c5bf6c2e0f8207bb7c1d3e6810899cfd72a1261aec16f88de63fe7aa3a8d65
-MISC metadata.xml 732 BLAKE2B 848d5250b057da4f922d0839d1ae304f6f7e921e6ee673a6829bc8a1c09db6829877c48a36b8e2db54d5f7964a18e380430ebf82dfa9652f30f28876296677ee SHA512 7c7b9c80d18fdf5ff7b7d9587e6cca737cf4b0e2ca89845087462dfd18acabf14e2c89e9b6d62c80e4a488a0e6a9364e50d15e034cbae6494d41d1b731396862
+EBUILD glance_store-2.3.0.ebuild 1659 BLAKE2B 2e869c3d8616a444b3becbdb560130f42e396c8d96d2cd6dac3403426b4c0203f7bde7a2d75b79d2ad40dda8b606026d63ed840071ad0c6550a96aa4f7945f09 SHA512 2761eab8823c91c2eb12d4ee0f6298acf0d4ba7b728a12e4a553ecc54f8a90922f0cd9546e81fea8d4c4e97565c0987e835d7644a58c0232ad064063850c6bc2
+MISC metadata.xml 756 BLAKE2B 446a0d4e98d1ceb702e5414c1f2b5b3d7dee58a853779df1aba88d917e24c5699f30b9b88a26b4e28393bb0b7f6e0e86db4fd6d63f1a9e06f9af707936f9c01a SHA512 7f2f27c0d280555cd49b177a1a983a544a40f9edf4b303c2000afbe1ddcaaf8a60dd693c0945c98bcdc15d7e1d0d0ce8a3b40183a54fa4ddc8972da796ff99c8
diff --git a/dev-python/glance_store/glance_store-2.3.0.ebuild b/dev-python/glance_store/glance_store-2.3.0.ebuild
new file mode 100644
index 000000000000..36beee1e75fb
--- /dev/null
+++ b/dev-python/glance_store/glance_store-2.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A library for glance"
+HOMEPAGE="https://github.com/openstack/glance_store"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="cinder swift vmware"
+
+DEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ cinder? (
+ >=dev-python/python-cinderclient-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/os-brick-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-rootwrap-5.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-privsep-1.23.0[${PYTHON_USEDEP}]
+ )
+ swift? (
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+ )
+ vmware? ( >=dev-python/oslo-vmware-2.17.0[${PYTHON_USEDEP}] )
+"
diff --git a/dev-python/glance_store/metadata.xml b/dev-python/glance_store/metadata.xml
index ce97dcbf2315..1daf50ebc007 100644
--- a/dev-python/glance_store/metadata.xml
+++ b/dev-python/glance_store/metadata.xml
@@ -9,6 +9,7 @@
<email>openstack@gentoo.org</email>
<name>Openstack</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">glance_store</remote-id>
<remote-id type="launchpad">oslo</remote-id>