summaryrefslogtreecommitdiff
path: root/dev-python/gmpy/gmpy-2.1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gmpy/gmpy-2.1.5.ebuild')
-rw-r--r--dev-python/gmpy/gmpy-2.1.5.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/gmpy/gmpy-2.1.5.ebuild b/dev-python/gmpy/gmpy-2.1.5.ebuild
deleted file mode 100644
index 458c53fc07e4..000000000000
--- a/dev-python/gmpy/gmpy-2.1.5.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYPI_PN="gmpy2"
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python bindings for GMP, MPC, MPFR and MPIR libraries"
-HOMEPAGE="
- https://github.com/aleaxit/gmpy/
- https://pypi.org/project/gmpy2/
-"
-
-LICENSE="LGPL-3+"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-DEPEND="
- >=dev-libs/mpc-1.0.2:=
- >=dev-libs/mpfr-3.1.2:=
- dev-libs/gmp:0=
-"
-RDEPEND="
- ${DEPEND}
-"
-
-distutils_enable_sphinx docs
-
-python_test() {
- cd test || die
- "${EPYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
-}