summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest6
-rw-r--r--dev-python/google-api-core/google-api-core-2.20.0.ebuild (renamed from dev-python/google-api-core/google-api-core-2.19.0.ebuild)5
-rw-r--r--dev-python/google-api-core/google-api-core-2.21.0.ebuild64
3 files changed, 70 insertions, 5 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index da53d563acce..e589075af8a1 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,5 @@
-DIST python-api-core-2.19.0.gh.tar.gz 210832 BLAKE2B 89947f8e8bda6de96c1778788e72f88c85d7781c4bf3c7fa08b67cd0e9b40e5774a57a5772add9c724a1bddab9ad514ddc605035289466a5648393ca57854321 SHA512 e8fb94428c3d49dcf760a0b9a471fa7fe3d149ebb11f8c12c16a0f68aaf736c5a8553d628834b4456d2419c40cc30010449ae58026271c32bbd32f67857ba31b
-EBUILD google-api-core-2.19.0.ebuild 1981 BLAKE2B 987067bd69c908f475ccc11f594fce1f8bea834a0e8cef91b030c7e4b19cb8a3250a7b50b678c4cca02548a3d3b011cf224507ff27dc12b405d1d86b6e4e65e7 SHA512 dcbe8bfef5b1ac9dbb5c1f8e33858b9065cda05ab735f2a3f0b96dafb534be0faceaa3dd143f1e0f1a1e1d84d0847752a9fdb7976a162eb43bc7f6df986cbeb1
+DIST python-api-core-2.20.0.gh.tar.gz 216778 BLAKE2B a6873f5bb07928933ab5dc04bd3e02ffab06c38c70661ff2da7e6ca183e49a0a4995b4b672f188ede14e416a953d3385ac564dd02ef643bd9cc63d0c16063e23 SHA512 4dd369da408acc15e54a1b7fd13cc2747d5a3ae3812cf42a3c0ec4a93245cc0f7c7cbef456ff19655e8d2d22955aec7369a295faef81cc4ea268c419ca62ef03
+DIST python-api-core-2.21.0.gh.tar.gz 223405 BLAKE2B 696489182ece170ab955193e8940a2235cc07892b5bcc319abe482bf7b673545b95dadeb5c1b49624d772dc36c9bcf19d28a91ad6aae07ef3215002eabfe6d5e SHA512 f1517c2ed4027013bdd7c11c4dda0c5ee67450c78247907422b3bcdd8d2f83958fb3ee6c65749056b2eeb734b05d584f4e9a9d0d133e220e3779602ef22e5527
+EBUILD google-api-core-2.20.0.ebuild 1946 BLAKE2B 2bc9751de68c1072642a7c834b7707d8456af3bb3f957eee8932576781202b49c089a5cb6902c42db23ad56680b850531fd341128bee19a71548d7c5f3754d19 SHA512 bfe5b327f67db8541b36c1ff60850654217559fee0704714dfc677e9c637e365e9c46fee8b20ed6ee034b4fbdadc6a1302c8b479b1cd44ff7b1cbe653158ad89
+EBUILD google-api-core-2.21.0.ebuild 1949 BLAKE2B 8bc8670d0f21412c241bfa0a73339f6d64f83f31c6e8bf2947d5726ab4a35b4af97c59e5e4de670c4d19b0bd5e0df3ac0b01e98fc38bc7564845bfc08d7ddec8 SHA512 bd8df0045557275174189a991cde0cd2f1d6bc5f5f041858e4131fee25cc5ff2051c4ac769437cefbc2a2caf846e3e13c0204a1849d119672dc8b2fdcd4e9cd9
MISC metadata.xml 519 BLAKE2B bf6ee9b3f0f7fe5fbfa5461aabf7872c803bd0483938da629ed6468017d82ac5b8736a52ef325374d7948a752ff1cfa6006aca2e833721f5a4a47f4adc5d8630 SHA512 d56b0312f5e5b5ba909c84af358bbfea98ea4098fbdd0ab562e0669a87a492facc05644d13fc38a196e1300f4cc1638b28cdcd10f412d753d71f8cf20a7fec62
diff --git a/dev-python/google-api-core/google-api-core-2.19.0.ebuild b/dev-python/google-api-core/google-api-core-2.20.0.ebuild
index 9b9d4cf25536..ddc45dbfe2d6 100644
--- a/dev-python/google-api-core/google-api-core-2.19.0.ebuild
+++ b/dev-python/google-api-core/google-api-core-2.20.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
+KEYWORDS="amd64 arm64 x86"
RDEPEND="
>=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
@@ -32,7 +32,6 @@ RDEPEND="
>=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
>=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
<dev-python/requests-3[${PYTHON_USEDEP}]
- !dev-python/namespace-google
"
BDEPEND="
test? (
diff --git a/dev-python/google-api-core/google-api-core-2.21.0.ebuild b/dev-python/google-api-core/google-api-core-2.21.0.ebuild
new file mode 100644
index 000000000000..61fa5cb4fa0b
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.21.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/proto-plus-1.22.3[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_test() {
+ rm -rf google || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio tests
+}