summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest7
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild43
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.6.2.ebuild44
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.6.5.ebuild44
-rw-r--r--dev-python/google-api-python-client/metadata.xml11
5 files changed, 149 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
new file mode 100644
index 000000000000..87ff7e0ee9c4
--- /dev/null
+++ b/dev-python/google-api-python-client/Manifest
@@ -0,0 +1,7 @@
+DIST google-api-python-client-1.5.3.tar.gz 3622355 BLAKE2B 1187729581c9e852a4512fdfd557785791c8102d6796f6d02d212820f9fe89393574ffbedc1445416ff2fa876269f18adb162a33241f6331e989a31ccafec60d SHA512 3f58af0d1f165fa7e045d08a0bfc282855b40dbea16d310bbc4cbce76f631b6303738a396048efc8ea114fdff1164d1ad303148999d0ab0ba0d2cc91df9408b3
+DIST google-api-python-client-1.6.2.tar.gz 4262337 BLAKE2B 0ae3e5b1c6bbb80999cfaadaef7812bb53d03eb1160f79a29bf73a180dae40bd2c5e7dceff0badaf5eda44718a06c4ec65fe993896a82c5fd12348f810ec2812 SHA512 ee906c2efb47469dc18dcfcb1edfad4346f61e88c1e7f73b60924b393c704e7033a5ff4f9a1965d0c29aa3a6bf25b60888e1d39366cbc1372861b49e79c9e886
+DIST google-api-python-client-1.6.5.tar.gz 4255929 BLAKE2B 4e2197fe56f25cd202f7a0b3f64b3796158d798bfedb9c0690a59c24bd5ce10fbe0300093ebb76cd343dae5eea2a0a360903cd0890834241926fd55a7dc07ea9 SHA512 b2f2be81e6f54ee3065e75ea064ea3ae49cb983d401ac46dca8459409dbd6df7c3ba07798285b5177bfa632a20d43aaaef3a7c73d5d565796567b8b305737565
+EBUILD google-api-python-client-1.5.3.ebuild 1132 BLAKE2B 57e30f9ca7eda67b6f280e9dcb014968bbe539d69b9f8bec97a807976fe172d13bf3f8cd2ff3e686712c1fd02f75b83584c7c0004a662035f1614cdb598a9f42 SHA512 3a4fb461c807189da1d26e3388fff90ece1a30ca9b8bfeb51841d7f68a36c7e8494ec7589d0760ac15e6744a5e5d4ddd691875ad5aeeedb9cdf54d37d2f29ee2
+EBUILD google-api-python-client-1.6.2.ebuild 1194 BLAKE2B ea6981dd0cb48f90f0c07237c5ebf8a3927cc2d3ad7f37ca07faede40e8a0b92ea63bd9ed092937495e19e3a64a4583bc13dfa7527e7320c433f0db7ed66e199 SHA512 41384e153fb18d48229bb57b7413267342e8ea8cdd5a560fb6fbef8aefb540dec712b410edb4b02b718d022b3349c87028d0d452d7b18b718d0590c7dd829665
+EBUILD google-api-python-client-1.6.5.ebuild 1194 BLAKE2B 0c9f20067803da8dbeb6f1f759ba8118282a4ece4c973ad55e7b2910f367c9cd893e1eb3fe68330374b1aaaf56f378bd44bddeda8a0ba3cd3a55717565b68d78 SHA512 cfe6616a9f1b4fda92b5a11bc793383c93f680b13150152325eee414ee75ea233292ce45e41dfb7f39c18d85eace00b5ef6641e9a4ddaf95b663021616a4efc7
+MISC metadata.xml 356 BLAKE2B 57ec373091acbeaf75beafc097b6b84f56bc052d9c27b0386e12579e3bef8ca955413d38344ecdac04c7f5a0ab463295a827efd5c6691db1cb958fc4a7f350f6 SHA512 e45fdf92fc9a3fcf08b74e9ac07326cced2cd7971b16a6cc4f96203199aafb9d72d36a29e3a924a43ce8dc4f3709add9c8bfcc8413bef028408cfb899eec9338
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild
new file mode 100644
index 000000000000..09dbe3dda09a
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-2[${PYTHON_USEDEP}]
+ <dev-python/oauth2client-3[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-0.6[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.6.2.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.6.2.ebuild
new file mode 100644
index 000000000000..d8e51fd1931d
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-1.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-2[${PYTHON_USEDEP}]
+ <dev-python/oauth2client-5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.6.5.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.6.5.ebuild
new file mode 100644
index 000000000000..0141e3fbcc9d
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-1.6.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-2[${PYTHON_USEDEP}]
+ <dev-python/oauth2client-5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}
diff --git a/dev-python/google-api-python-client/metadata.xml b/dev-python/google-api-python-client/metadata.xml
new file mode 100644
index 000000000000..8d8cdc3a5875
--- /dev/null
+++ b/dev-python/google-api-python-client/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/google-api-python-client</remote-id>
+ </upstream>
+</pkgmetadata>