summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest3
-rw-r--r--dev-python/google-api-python-client/files/google-api-python-client-1.8.3-tests.patch28
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.8.3.ebuild48
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index d16e316c66fc..30b4f12b1066 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,8 @@
+AUX google-api-python-client-1.8.3-tests.patch 1118 BLAKE2B 41900d0b3358128626090b94f8e2a1f767a31dce97efb3c7c5750704a27f9c962cde240caafcc883497b71209c7c8b6733464d1dfee00ad13d2707cb2beee397 SHA512 a14830727ab93bece5c65d303276b6ba85c5fbe8335d97be2f0478a7ab1d37d9be688c859b4ff4ecaf966a9d95f245276c81dd4d7d4e9bb31164a33ecabf32ac
DIST google-api-python-client-1.6.5.tar.gz 4255929 BLAKE2B 4e2197fe56f25cd202f7a0b3f64b3796158d798bfedb9c0690a59c24bd5ce10fbe0300093ebb76cd343dae5eea2a0a360903cd0890834241926fd55a7dc07ea9 SHA512 b2f2be81e6f54ee3065e75ea064ea3ae49cb983d401ac46dca8459409dbd6df7c3ba07798285b5177bfa632a20d43aaaef3a7c73d5d565796567b8b305737565
DIST google-api-python-client-1.7.9.tar.gz 4142239 BLAKE2B 1754162cd7ae5aa64e105e4842ac415473949064576241453ba5aefcc9c53e3a070167d4210f49509a5f63d4b9e79fa5377119ccd53acafe24eaad4a39e5f8c7 SHA512 1e4410c5e639a6bd3cf12b3e648a63e0098182bb52196085dc92597a38e98984fd349adc282d688aa58ec263502d984f54c7827b7ce53128811e7137234358b6
+DIST google-api-python-client-1.8.3.tar.gz 13537177 BLAKE2B 00b1d46f349a8ad66d08a01da31aed224260ad38f0ee2d7a5b68afe29264234475d28b33cd95addf9f7020fa052e9528b01a4c9cdb73e2ca5742134c4f8f86b5 SHA512 7b9138b27bf032cc1b8beb321459ba5935ed31e4965fa783e472b9483cfd0e97c1da6a34e84fb8c939c462fac462d3f0d853266586ab37be8f890a6b873cf4e6
EBUILD google-api-python-client-1.6.5.ebuild 1201 BLAKE2B 576e80db7392ff11fc7b3d65ef769ae93ac90957517a68567d0fea4495b0f762d74f2bfa09f05a5f1ec0c7d1ac268fb0673d0eccff1808e92bdae647f49738e0 SHA512 97dff39cfaa8821667295567b3b832033e00cddfc13b9e22442ab528be6f0bcc582ecc5ef06bb8d631086756dcb93afa3284e9985a6c24ec8b922f9d69a3b271
EBUILD google-api-python-client-1.7.9.ebuild 1219 BLAKE2B 359ad0ee52e34de758e66bc76dc46979791858f369f8da19bb6d7cd593eb02d48702ae84eb02a7aea7b76243b263d617451f8558ca9957feef568e009ba8c700 SHA512 688f94149df1282369234c8ef0eac9b8bc7f2ba353f00f7c40f5aa5881fb1f81734baf98913cfca3151742ef3b3f15c4a7c6fd5713bbb825326ef248fd8ce51a
+EBUILD google-api-python-client-1.8.3.ebuild 1300 BLAKE2B 0dc0376aa30b9d55e1e1a96982a5b6f247871d0e1313a6dc7ab22c736b2c7373a4d4c75d3443845bb28448d9688fd2ef36d02db0b7d03af7904ec390fc952f8b SHA512 1ea08d6d2d47428b59b4debba8bc3abbd37fc97f7f7beb336c555099dd34ad21173969c70093149e4a93f859287fae2ff7b4667a8fe04fd4f54119adb1f4ce28
MISC metadata.xml 381 BLAKE2B 2a802e6c566da699864dd520badb0a91eed1b7a1f26e3f20d6bd6bf7993325d07859034694d7d510984835369ea27a0c25241d9d202b3fc31fa2b52d26e42b6f SHA512 02a4ce0b16adaeaa44e041a2bfc0a4f97eb63914d10064403dae1581e3fdfda93673bb750a60e56b83c0bee46395266f7a5b846dfd65bf157253c733c8077216
diff --git a/dev-python/google-api-python-client/files/google-api-python-client-1.8.3-tests.patch b/dev-python/google-api-python-client/files/google-api-python-client-1.8.3-tests.patch
new file mode 100644
index 000000000000..ad875e728314
--- /dev/null
+++ b/dev-python/google-api-python-client/files/google-api-python-client-1.8.3-tests.patch
@@ -0,0 +1,28 @@
+diff --git a/tests/test_discovery.py b/tests/test_discovery.py
+index 6400f214..c999fd4f 100644
+--- a/tests/test_discovery.py
++++ b/tests/test_discovery.py
+@@ -40,6 +40,7 @@ import sys
+ import unittest2 as unittest
+
+ import mock
++import pytest
+
+ import google.auth.credentials
+ import google_auth_httplib2
+@@ -515,6 +516,7 @@ class DiscoveryFromDocument(unittest.TestCase):
+ # application default credentials were used.
+ self.assertNotIsInstance(plus._http, google_auth_httplib2.AuthorizedHttp)
+
++ @pytest.mark.skip("Needs network access and credentials")
+ def test_api_endpoint_override_from_client_options(self):
+ discovery = open(datafile("plus.json")).read()
+ api_endpoint = "https://foo.googleapis.com/"
+@@ -525,6 +527,7 @@ class DiscoveryFromDocument(unittest.TestCase):
+
+ self.assertEqual(plus._baseUrl, api_endpoint)
+
++ @pytest.mark.skip("Needs network access and credentials")
+ def test_api_endpoint_override_from_client_options_dict(self):
+ discovery = open(datafile("plus.json")).read()
+ api_endpoint = "https://foo.googleapis.com/"
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.8.3.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.8.3.ebuild
new file mode 100644
index 000000000000..41edd77cf759
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-1.8.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.0.3[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/google-api-python-client-1.8.3-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests fail with ${EPYTHON}"
+}