summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1-r1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index fd09751666ee..a346bd4d189a 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-oauthlib-0.4.1.tar.gz 18687 BLAKE2B 1c9028f6b4c306bbee51fba5b55950d129d56ff5154645a166998c0c720b125202731f1cfed60837b8103d56fcdeeb818e39491b243a8d761969f73d9f88f67b SHA512 123707139353db8e05c81138af834e35007d323f0e19ae79088ad5ca4be86dda6c0df91e2f7794711475227a60312fab9101c91b49817bf8b84866ea6374c943
+EBUILD google-auth-oauthlib-0.4.1-r1.ebuild 631 BLAKE2B 9a87391320fae8ad83b4896f8c8ff40cee0c5823e2cc9832870064dc9aea58b1b52219d7c65482e68dd95bdee6422da2aefce734729c7a574cf7490349121036 SHA512 2552e0378adf25366af9a71e81325ac1e9910a1c7edc18b45618fa0294e6c707717dd908d3f23109f092cc0737ce00075d9aa844bc693953f44f27a74ac4d51a
EBUILD google-auth-oauthlib-0.4.1.ebuild 629 BLAKE2B 0cb2298c2fecf924e22458c8652d9f9d461f183444c234e4f5817954cb95e498630ebbfa4b75a2d38995cbd74b946518729bd47f6a45ed0ecd48b8fd6555e95b SHA512 41d56a3d6105833824b666862769d6a2c4ffc8e60abbb4f10f98cb598915d07f66cc34067a6537726ef6a299e32d35313d3f097f2087ce25659df9d0778784ea
MISC metadata.xml 255 BLAKE2B c4c803a94d6885a8abc62874a17e76c1a13cc6a00ec4584d189c44c3e37fc87ef14b803739705e4e0051f57fcd1e475f4374ba28eb4520590b990ca53b16b272 SHA512 aca82b710a2d8d4338aead6d3e0443bd3d2175cc7bb4e2e72fee0535d0f0305bc55b87bbd9c87cc2385d7a7d4cfe81a4f123f9ba9010f667fcdc892a9883a362
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1-r1.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..ba3dc19e098d
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://pypi.org/project/google-auth-oauthlib/ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"