summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest6
-rw-r--r--dev-python/google-auth/google-auth-2.34.0.ebuild (renamed from dev-python/google-auth/google-auth-2.29.0.ebuild)8
-rw-r--r--dev-python/google-auth/google-auth-2.35.0.ebuild59
3 files changed, 67 insertions, 6 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index aefe53638403..38f8481bca13 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,5 @@
-DIST google-auth-2.29.0.tar.gz 244326 BLAKE2B 36b0bd8f445e3c7c3e0a83d07cf5924401dec99cdd22a6042bf5b9ca1cc9b1e28d0029f8f1509bcb32a7c54abd7c453dd5077ad25886d265822cf1c880b1326f SHA512 0f6d7e9728479a5937d72321f5ae6cfa3592dd42bb518a5519fc0936b533472e872fe947470a1774f8e53a2dad3c65e001de3899b74b6373dd149c6944423473
-EBUILD google-auth-2.29.0.ebuild 1439 BLAKE2B 7f1d474e335a4a6ec0a86d6f47d69accd6ae97bb5ff53f1d1c4e8d78c79ffcbaf3f1a633a279936276ecf707cc2455f494a68a599c3299f06e73090e08d3b4c3 SHA512 cedc905deb31d47c3581d26b8b7765145452a281c0ca0ba79966b47d1f20779ab41e6c321b3ced80b7d805bd3d9ab47cdf041e3d0c727b69c88059b584e6b54a
+DIST google_auth-2.34.0.tar.gz 257875 BLAKE2B 3ebd19aff528673e2240769b606cc6c88cead7dad4beafd58966fe4534a7a5b016daac448658992d5210a69749968975bfb9de462fa8de5891f1412c141b2cad SHA512 fd023bb3d8803e267a7c50536a30e749cfe388e95bd580556e9a60c88c093eb70b93493c4d277dcc77588a43644d90a0c5b80cab946b29f37af99ee913571b8b
+DIST google_auth-2.35.0.tar.gz 267223 BLAKE2B d30c8ca15f0e8183c1d50c285d578d8373bf722dddbeb2d5e423b2e25b26f038d406a6dccacf2cebbb0741a2ef07e8b0c86d0362734db3a56054ff76b6d213d7 SHA512 5c359bb94f213812c57cc2c2942d1da3aa08f0e73dde6f5b6c2f563fb51056009f3b821ec0fc39571221da267011d850c242a5ab044d88648be44759f7337973
+EBUILD google-auth-2.34.0.ebuild 1471 BLAKE2B 3668cb2042daa1cd03aef840c76585899f05df7a7629b8a2bd275d2fc7926ccbd35146ac6fce8f48b2a84ad24e5c067b124292874a259b310e3cf1f34438784f SHA512 0878e8af6a42199544b02b779563f6af9e0a4d285ede7750fdb3f99b7d0885687249b8a4e96dabaea55416213d930e1b74e20d5a624e5077061fcac9084934b8
+EBUILD google-auth-2.35.0.ebuild 1474 BLAKE2B 4a3e857ea3a00984e7708742978efc875a86333f0a212a4be41db07577d226933f7113d3d88c971b554b4ef3c5f3c72aba7f98a6e68400d8051f8559f6213512 SHA512 6562f6b387baae59127b5bf7522a3bde938fe929004896ef4f2a3251c2ccb8bc0b7ca5329dd3879d5cf943a950590a745c9dbb128e860bbaaf6c8aba3be8acb4
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.29.0.ebuild b/dev-python/google-auth/google-auth-2.34.0.ebuild
index 9cfd3b0ae33e..dc9a27d8e5d6 100644
--- a/dev-python/google-auth/google-auth-2.29.0.ebuild
+++ b/dev-python/google-auth/google-auth-2.34.0.ebuild
@@ -4,8 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
@@ -17,7 +16,7 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
+KEYWORDS="amd64 arm64 x86"
RDEPEND="
<dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
@@ -33,6 +32,7 @@ BDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
dev-python/moto[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pytest-localserver[${PYTHON_USEDEP}]
dev-python/pyu2f[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
@@ -50,7 +50,7 @@ python_test() {
)
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
+ epytest -p asyncio
}
python_compile() {
diff --git a/dev-python/google-auth/google-auth-2.35.0.ebuild b/dev-python/google-auth/google-auth-2.35.0.ebuild
new file mode 100644
index 000000000000..5778ba5b4f5d
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.35.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}