summaryrefslogtreecommitdiff
path: root/dev-python/griffe
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest2
-rw-r--r--dev-python/griffe/griffe-1.6.0.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index 5de5e1d8ea09..3b12616d5431 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1,3 +1,5 @@
DIST griffe-1.5.7.gh.tar.gz 393455 BLAKE2B d294a62e131ce5276c52e3f11adef5081c10131156cdb3c112761569d3776091e1c1dfea445252cc3595572baf1caab416ff510d89f84a4511d147f1aa36b762 SHA512 cfea773780a645f92f8ad32b0f2e682561f63cf3082f2e24bd1f944f1a907b35db15883cb7df726d34e03373e73fe5e855f3d00a455cc01cac265bced822b4ed
+DIST griffe-1.6.0.gh.tar.gz 393773 BLAKE2B 62f1ed8109353013e2ef10bf32359dc66c467641b62ff0ecceb49718cafc773c5aab2cc151797e023dbff96f476e8b67d3bd7f5b664e3f5d6ea96f20e1744b60 SHA512 8ce0565ba8c43afb262d7e65b2eab369b10a57d4855a226a83ffea60bd83d7f624d5f15876c51dd20861ba5d652c012245bd55dd87dd0beeda75305f26f330bf
EBUILD griffe-1.5.7.ebuild 1611 BLAKE2B bf144e59f05ea48ef819c3e125202397c32303869af653ec39ecc1e77b9dffe9369c996203a30f4366db1e33f6234b849bfca1bd7db4113a6109d53cf5ce2d3d SHA512 cdc7e8e33a2901c58d634987d8d296a5e062cc8c3d4c4171f049c382f646a7ee976a74d95ac34edf9eab580cd5b4a04ea4175dde51179f952368b2275c9f1c54
+EBUILD griffe-1.6.0.ebuild 1611 BLAKE2B bf144e59f05ea48ef819c3e125202397c32303869af653ec39ecc1e77b9dffe9369c996203a30f4366db1e33f6234b849bfca1bd7db4113a6109d53cf5ce2d3d SHA512 cdc7e8e33a2901c58d634987d8d296a5e062cc8c3d4c4171f049c382f646a7ee976a74d95ac34edf9eab580cd5b4a04ea4175dde51179f952368b2275c9f1c54
MISC metadata.xml 393 BLAKE2B f207ed2887879f849db9133aac5b82d507a5c6fc3fed0b931dd0aec5ec8d48991731a15825c7b51d82f1f148c2f6818e3102e963d3342aa248bd475d4b29a692 SHA512 b541674c9f9bf9e356d46de91673e384f50ade9b6f19b0218f03b6e307dde88df2d0078f202bc0a77e18b0d91e89cb6d36ffdac23689ef35306167619404dc01
diff --git a/dev-python/griffe/griffe-1.6.0.ebuild b/dev-python/griffe/griffe-1.6.0.ebuild
new file mode 100644
index 000000000000..115d0beb002b
--- /dev/null
+++ b/dev-python/griffe/griffe-1.6.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/backports-strenum-1.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ >=dev-python/mkdocstrings-0.28.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+ )
+
+ case ${EPYTHON} in
+ pypy3.11)
+ EPYTEST_DESELECT+=(
+ # https://github.com/pypy/pypy/issues/5226
+ tests/test_inspector.py::test_inspecting_objects_from_private_builtin_stdlib_moduless
+ )
+ ;&
+ pypy3*)
+ EPYTEST_DESELECT+=(
+ # tries importing CPython-specific modules
+ # https://github.com/mkdocstrings/griffe/issues/362
+ tests/test_loader.py::test_load_builtin_modules
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}