summaryrefslogtreecommitdiff
path: root/dev-python/h5py
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/Manifest2
-rw-r--r--dev-python/h5py/h5py-3.13.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
index 870c8cfc870f..0fa735eb494a 100644
--- a/dev-python/h5py/Manifest
+++ b/dev-python/h5py/Manifest
@@ -1,3 +1,5 @@
DIST h5py-3.12.1.tar.gz 411457 BLAKE2B c8e2bb453b9f7f1a79b9061ec3564bd8f1175c286a163b43f340cb9fc93f0e279131e4ed658066b870237046766aaff1289f22d84ee318108c96840d257baafa SHA512 a96dc5b7a14408c73db3ef758e0d3cff5d4469d6efe19a71af69e049f434aa62f01fbf44464cc5a3d15b89f00b9864cbb42b1b1e59bf3f520b458007f8819cd3
+DIST h5py-3.13.0.tar.gz 414876 BLAKE2B 4c46711c78c6d88a50e4dbb046b55cba003be87199fe25f74c2dfedd04503a79e1b0d3e01b353e8a02066f6824168f666d8a96b6a834093e165060da1402be36 SHA512 9f9f6aab8d4e82dcc64d8ae20e6ecdd894c37313c8234fd14b84af08afaf2847bdce1334e86026381dc45a3edf8f1954c6e8acfc553140f2bd42315f64a30b76
EBUILD h5py-3.12.1.ebuild 1329 BLAKE2B 80852452c958f6f4c664c5cc8245c4a0c5368a42978cd0f7a3b8fd5a3efc1bf8259f6acf1575397c6099a6abf3dbb216ee6d772e6def44575449f3d8eaffee7b SHA512 060e582abc2113ce0086bf4d2458971c600cb61559c69714270e6794bccbd6fb66c0edf50d7bdd2ec5b4172044e6f093d75bb1367501019868f5f9fceeb26c51
+EBUILD h5py-3.13.0.ebuild 1332 BLAKE2B 5ea184933e8a6b67b931d73b175e05e42c39818136dcadc3edeb4a13440bcb4eb97296de8fe6580c7f47db2428b13d505ce4b7831d60e6d408f98258643d3b41 SHA512 bab76745342424af4ebe191ebb88b6bb3cdda7f587ac3565d3c5cc6e3a0698a8d7504d27b2636f0b204f0789306e05eb04d63c924235cd0a1f0711240bfa4ea2
MISC metadata.xml 1069 BLAKE2B 0f3ef8e7af7f4bb493824427a238588c019c04c28fe8a4b9c0b9af1c986158eb3dae3b7d7937713cc4c87374ef80686603ccdbae2baff5b1150d814ab108d973 SHA512 47a6074e383cc922234ebb9f67aaa5863421eaeb2003444587bb8499b3bf845da93ac8d8d267717bea01300691df10f67c9389248fbe228afe07c17fba3a64f3
diff --git a/dev-python/h5py/h5py-3.13.0.ebuild b/dev-python/h5py/h5py-3.13.0.ebuild
new file mode 100644
index 000000000000..45485b140535
--- /dev/null
+++ b/dev-python/h5py/h5py-3.13.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="
+ https://www.h5py.org/
+ https://github.com/h5py/h5py/
+ https://pypi.org/project/h5py/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+DEPEND="
+ >=dev-python/numpy-1.17.3:=[${PYTHON_USEDEP}]
+ >=sci-libs/hdf5-1.10.4:=[hl(+)]
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+BDEPEND="
+ >=dev-python/cython-0.29.31[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/qtpy[testlib,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+
+python_prepare_all() {
+ # avoid pytest-mpi dep, we do not use mpi anyway
+ sed -i -e 's:pytest-mpi::' pytest.ini || die
+ distutils-r1_python_prepare_all
+
+ export H5PY_SETUP_REQUIRES=0
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest -m "not mpi"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}