summaryrefslogtreecommitdiff
path: root/dev-python/hidapi
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hidapi')
-rw-r--r--dev-python/hidapi/Manifest4
-rw-r--r--dev-python/hidapi/hidapi-0.14.0.ebuild4
-rw-r--r--dev-python/hidapi/hidapi-0.14.0_p2.ebuild43
3 files changed, 48 insertions, 3 deletions
diff --git a/dev-python/hidapi/Manifest b/dev-python/hidapi/Manifest
index bb6638279a42..0d2f9eab74d3 100644
--- a/dev-python/hidapi/Manifest
+++ b/dev-python/hidapi/Manifest
@@ -1,4 +1,6 @@
AUX hidapi-0.14.0-cython3.patch 3670 BLAKE2B c474480208fe8320d08ce6be18931079de4afb78749d573ae58ec99c96fca81a490e4661ca3a42b876d8b02d0479d37244578b27f3c5c964bb7ee4dadad94958 SHA512 b109db4162092ee8179031802ecd06676b9ca09685f9e98efde6d432fe7b32863d815b759fb5d3e45ff7922a0922b3d3abdf1d08e743801a9c86b2fede2144a2
+DIST hidapi-0.14.0.post2.tar.gz 172542 BLAKE2B 7f9028b913a3fcbe893ecbe73210ef465ce08cd12f807c234964550756a56aacc9a2a32c237e86d3028d5116dccabf67ee85cfaa4d806ef63357d57a8e65cddf SHA512 ae1bc66a42b6dbeae0913a62909d24ef11801f6709cef6a33fb9f888a985782b64452dea2f79caee5aa7c6a49cab7af9ff5717cee4fe52fe6137096332180bd4
DIST hidapi-0.14.0.tar.gz 143052 BLAKE2B ebf3fb9608b1f18d9fa24aaa4bca7b2e5cbbbbcbdb6a33da41456f614d0cace556231bb8eb17c21e2a79a5292970cb37f7a46fb6cd1e82efb0a646cf8a942d2a SHA512 228fac22621e36a3108cefd418937a7ed0153e334e19999e947aad341a753d614877cd3f7add90d78037ebe9c7b3f6cbc42973a8e680188da14928311d317b17
-EBUILD hidapi-0.14.0.ebuild 698 BLAKE2B 67518e045f446d5b0c609daf648e37f2af781018f9acd641a1eb81dac0883f7573dadbc902dd148fd9889e08dc5b951425bf867e6c57d095fb1c9142676ff83e SHA512 1acc599831727c4763ef5e8cc6aaba05c1ddd7ebb91a75c730d3efbf903b1370b1d93c9af0797385c8f02f914b73f18f62088f602dd01f01efe7addf17f135ae
+EBUILD hidapi-0.14.0.ebuild 698 BLAKE2B 4e97c1363d4e5fec1bdceb2da7c5dfd1d5835f7212d772b49528067c17407dc8edaa1b6665dc69edfb1c9f8b040895d1133e3fd50b7acc0a2fc0774c64a8d799 SHA512 23eaabdeb2ec4ffe8594988119438ffde008de8c85de7906aa60bec8df442f13fd5fd6e35a58b4f72a9ce303c4561fcb4024431c345f5fa23dc84ec9418852f6
+EBUILD hidapi-0.14.0_p2.ebuild 713 BLAKE2B 9824dea0aebecd617d699cb28e4f937cb64dceeb9850d800af45353a6693e4990893fd5cdf2876eb34fad27a75e0503da4e79724b5de5c13135c3f81f0b4e9a5 SHA512 7327f7c532fea8822540f74290b6ab974704cf7f0e94b489c2b42bdd9b09e540e0c10cf07343127cb15be1acef9589fad779eaca4378e897489d40f1a15348c4
MISC metadata.xml 304 BLAKE2B 69f2abf7c43eda718abb98bdee59b648ca8562d77c2d8381ee7dc83e4b7d1d0f017dce9a291a783ba3891b54df905a49da3f74916158b9b72f6b6f12674b0b53 SHA512 d06b9d8c5b35cda24fb8fc01206e610d0fc78e723833817207c9c18e4b2d02df82cac832580ccd917c68be399d7115024f0b573acd8705d89306f88790cfdbc3
diff --git a/dev-python/hidapi/hidapi-0.14.0.ebuild b/dev-python/hidapi/hidapi-0.14.0.ebuild
index 890f3675ed06..c3ee2cf692d0 100644
--- a/dev-python/hidapi/hidapi-0.14.0.ebuild
+++ b/dev-python/hidapi/hidapi-0.14.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_EXT=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
diff --git a/dev-python/hidapi/hidapi-0.14.0_p2.ebuild b/dev-python/hidapi/hidapi-0.14.0_p2.ebuild
new file mode 100644
index 000000000000..5b71e5edf404
--- /dev/null
+++ b/dev-python/hidapi/hidapi-0.14.0_p2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Cython interface to HIDAPI library"
+HOMEPAGE="
+ https://github.com/trezor/cython-hidapi/
+ https://pypi.org/project/hidapi/
+"
+
+LICENSE="|| ( BSD GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/hidapi-$(ver_cut 1-3)
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+"
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+ DISTUTILS_ARGS=(
+ --with-system-hidapi
+ )
+}
+
+python_test() {
+ epytest tests.py
+}