summaryrefslogtreecommitdiff
path: root/dev-python/httpbin/httpbin-0.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpbin/httpbin-0.4.1.ebuild')
-rw-r--r--dev-python/httpbin/httpbin-0.4.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/httpbin/httpbin-0.4.1.ebuild b/dev-python/httpbin/httpbin-0.4.1.ebuild
deleted file mode 100644
index 9491c99543c6..000000000000
--- a/dev-python/httpbin/httpbin-0.4.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP Request and Response Service"
-HOMEPAGE="https://github.com/Runscope/httpbin https://pypi.org/project/httpbin/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/werkzeug[${PYTHON_USEDEP}] )"
-
-# Not included
-# Someone needs to file a bug upstream
-RESTRICT=test
-
-python_test() {
- ${PYTHON} test_httpbin.py || die
-}