summaryrefslogtreecommitdiff
path: root/dev-python/httplib2
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/Manifest2
-rw-r--r--dev-python/httplib2/httplib2-0.22.0.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/httplib2/Manifest b/dev-python/httplib2/Manifest
index e7b4377e2e71..76b1d8f72c2f 100644
--- a/dev-python/httplib2/Manifest
+++ b/dev-python/httplib2/Manifest
@@ -1,4 +1,6 @@
AUX httplib2-0.12.1-use-system-cacerts.patch 582 BLAKE2B ee2a407452ab557eec0934a175958ac7f1d1af3ad588b7f288b9e9f0a3d2b08146fdee05943e2681a1462986098256fa818d9561a4541ba0ed3b95984172271f SHA512 ff1b982e9f95f6efa53064b2a8d2748bf5a91a26fdaeb584f044d8e036b91034dbcf4719cb08855de412d6abcc33fe82e18fbd250c14d0ae2fea47b412fcafc3
DIST httplib2-0.21.0.gh.tar.gz 373245 BLAKE2B d7194773c2b61cbf579da5aea7f52cb3481eed86896be215b942de7f9418a39c4a934868c9e01b6bfb050a32e4b7bc7ff775b28af5ba5db2827131e436bf0b04 SHA512 8269014f05f5e4b668c7dea8ae708b27a60b4216d712a93ab58b74f399ab5bc0dcdcd8c1411ccff587c7bdb6bc20917451ad969e5bef2d5c5262327cabe17bbb
+DIST httplib2-0.22.0.gh.tar.gz 373972 BLAKE2B 6adfbc61d4f898666512da5d02cf082fcaf76bf1816de955510f5c4721a36c38d99fef963d5150b62cca091543ed65bb1ef5f33ce99123e1cd2abe467d4970e3 SHA512 77210f85ccaa2d2cf4a6c89f5146ca5eb9a6f26f00e862f6d0716ec73baffdf94714ae1d5eaced4349920b91276a7835e2f028c6d9156e84c241514b198791e5
EBUILD httplib2-0.21.0.ebuild 1859 BLAKE2B bbe446a39165ac74ceafcdd50d37fdbf0bc06f63beb32782421dec8479602c2b03ed541ff311235833863a51d44e3e5512a8ead0ab329c3c5a193fe492775a2c SHA512 6de23bec28b84c5e3d610696f99965cb613845d6a74814eba1db2fe9d18bc229d341705a730c5a8ea6c0bc5dcb92274e9bf2f3b7fbfab4be25fb53d9494c845c
+EBUILD httplib2-0.22.0.ebuild 1867 BLAKE2B 51cdae1dbfcccaf0a9b7d1b964d3df97af7c7d60b43b01ac03728e4dd0def426c94bb3e25892005355fbb5c021a9550d890a523a161f18c9cc86de08f737fce1 SHA512 08dd706674820651667ebea27775b173096dbf3e96b5e178682737c44fbf158630a40282de1176c7ba0eaffe78a22fcbfe942c62bbed49064175056ce51d94fb
MISC metadata.xml 406 BLAKE2B fcac2ef4d82fd109083a57097d0e8b99e1fbb3103a2e8ffa29cd77acc0300b0d91d30661a5721f25680b822a1e0f22e4e457fa05bd8948c68b0e3712146a3de6 SHA512 5a94811b95720f0bdb57c725e35313ecc5a15f12a8f75e39c9034440eed957cfb3dd9e86437c0c7b1df51f47602723a7e94ce2b62509dab4eaa4feac02e1558c
diff --git a/dev-python/httplib2/httplib2-0.22.0.ebuild b/dev-python/httplib2/httplib2-0.22.0.ebuild
new file mode 100644
index 000000000000..2b1549a355b3
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.22.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="
+ https://pypi.org/project/httplib2/
+ https://github.com/httplib2/httplib2/
+"
+SRC_URI="
+ https://github.com/httplib2/httplib2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ app-misc/ca-certificates
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-libs/openssl
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ # cryptography dep is entirely optional, and has a good fallback
+ sed -i -e 's:from cryptography.*:pass:' tests/__init__.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by using system certificates
+ tests/test_cacerts_from_env.py::test_certs_file_from_builtin
+ tests/test_cacerts_from_env.py::test_certs_file_from_environment
+ tests/test_cacerts_from_env.py::test_with_certifi_removed_from_modules
+
+ # broken by new PySocks, probably
+ tests/test_proxy.py::test_server_not_found_error_is_raised_for_invalid_hostname
+ tests/test_proxy.py::test_socks5_auth
+
+ # broken by recerting (TODO)
+ tests/test_https.py::test_min_tls_version
+ tests/test_https.py::test_max_tls_version
+
+ # new cryptography or openssl-3?
+ tests/test_https.py::test_client_cert_password_verified
+ )
+
+ # tests in python* are replaced by tests/
+ # upstream fails at cleaning up stuff
+ epytest tests
+}