summaryrefslogtreecommitdiff
path: root/dev-python/httpx
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest2
-rw-r--r--dev-python/httpx/httpx-0.23.3.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
index a4a5b0e766f8..2ad71bbe782f 100644
--- a/dev-python/httpx/Manifest
+++ b/dev-python/httpx/Manifest
@@ -1,5 +1,7 @@
DIST httpx-0.23.1.gh.tar.gz 2161798 BLAKE2B ee01771377bbfebbc4a9346280c8d59508c78295e61b6f9d60a07099e44dfb0fc208d37b68f511bbbacb48438cf6daa73ef82d7a7ae75470409c8346ddad0ad5 SHA512 3fe280b6d3cb1a12bdd502e7bd432588375f9cebfcd9e071acb6e851866a56d84a715428599a297f5df43d73997b2a0c02ba1a12b3e32d292b2051161a350751
DIST httpx-0.23.2.gh.tar.gz 2163739 BLAKE2B fe89a162749e8710f6392ce3a2eb887a4ee0053270ad4ce20cb74d6fb4e70a14c800755ea2b32166f11e3dcb74a3c7d50a3e3a0644fa489a89f9f65050b826a4 SHA512 49b0b8cd3ba3f4c18fcfaab5e9ac52bfacb80241aa2b8452542a274a4b203ef6b35d936ad7f9a0b1e0d9857b1394a4e388572676cd288c8fb20f78a6df3ada4c
+DIST httpx-0.23.3.gh.tar.gz 2163546 BLAKE2B 96903669ca9d22cbb85bd322a407aa2b6799b5f8bfce277a763248ac2d65d60b85c0c71f24af99098eaca585f8136d9db687d6d0ab8cf2347d3c6fe28222def0 SHA512 d4f051578de63e677492727c466d44858c31d1b85441621667d4aeaec5cd2ebd0257a1db115f1b4d77d563359dfc81c2cd1221c0cc66c891b461fa1f4e8a5aee
EBUILD httpx-0.23.1-r1.ebuild 2170 BLAKE2B 351d8ae5566b7b7341540df0f28dbfb7689531343a0291eab21086cb2400380414f6c24dda191c0209a6d7d21fe8f6facea443a2d5c88e7791648073a7641752 SHA512 c228cd845319691d1c7c0678e18c5d6d81956b08e10e63bc27351938ca0fefda440f5446a7e60253429dc6999dbd95c86f1dcc334bd01c3b53d8f0edb748e133
EBUILD httpx-0.23.2.ebuild 2183 BLAKE2B 7f2df7f82df88c085f6b4d12501112830e5839a0815b61ac38c0cea4e9ffbde557533a3b7319c1413ea0c59648a5fd40b863c71e1198f9fcb2e4dcc2ca7f08e9 SHA512 781b903aee1d0029d10108d5948de525c11b42105cdb3adce1ce550b6d86f454acca16cb8ef2c59840dcc55d166c74ccf4c9ba12d08198214dac5be504340038
+EBUILD httpx-0.23.3.ebuild 2050 BLAKE2B cef1f9dc0b4f1fedbb8de112cbc1ff3fd8c9b7fe9839d6d4f09a3cd19800315365453698d0b6d0b83f117ca2ac4f4dc9d2cf6f7ef54c1a916a2ff1c881e62b31 SHA512 bfd801f1a242eed588c27dce96a1257fb4c37f625db489783451e8ab419d5d0bd114432c322dbe63561d4f04acd84cbbc002d2109f3219d61dd893bc79d9e168
MISC metadata.xml 518 BLAKE2B 063b5b95529cd5a31aac83998c0acbdfef208c34e931c96ae8ee767a326301a597a8297514b5c97bef2b3b706b8938d38c0e5f5d752307a9dd06984792c799a2 SHA512 3a29dffa0f951255a67468b28917590d4108ca12e14af03bfddef80f6d48e266fcccdd991e778ab9e267c0bc76ff0017e07905c1f2f45dc440a9af89f6cae6aa
diff --git a/dev-python/httpx/httpx-0.23.3.ebuild b/dev-python/httpx/httpx-0.23.3.ebuild
new file mode 100644
index 000000000000..8bdd6f0fea7d
--- /dev/null
+++ b/dev-python/httpx/httpx-0.23.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1 optfeature # docs
+
+DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
+HOMEPAGE="
+ https://www.python-httpx.org/
+ https://github.com/encode/httpx/
+ https://pypi.org/project/httpx/
+"
+SRC_URI="
+ https://github.com/encode/httpx/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/httpcore-0.17[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.15[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.3[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ cli? (
+ =dev-python/click-8*[${PYTHON_USEDEP}]
+ =dev-python/pygments-2*[${PYTHON_USEDEP}]
+ <dev-python/rich-13[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/h2[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if ! use cli; then
+ sed -i -e '/^httpx =/d' pyproject.toml || die
+ fi
+ sed -i -e '/rfc3986/s:,<2::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/client/test_proxies.py::test_async_proxy_close
+ tests/client/test_proxies.py::test_sync_proxy_close
+ )
+
+ use cli || EPYTEST_IGNORE+=(
+ tests/test_main.py
+ )
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "HTTP/2 support" dev-python/h2
+ optfeature "SOCKS proxy support" dev-python/socksio
+ optfeature "Decoding for brotli compressed responses" dev-python/brotlicffi
+}