summaryrefslogtreecommitdiff
path: root/dev-python/humanize/humanize-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/humanize/humanize-0.5.1.ebuild')
-rw-r--r--dev-python/humanize/humanize-0.5.1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/humanize/humanize-0.5.1.ebuild b/dev-python/humanize/humanize-0.5.1.ebuild
deleted file mode 100644
index 9fb7249b70dd..000000000000
--- a/dev-python/humanize/humanize-0.5.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Common humanization utilities"
-HOMEPAGE="https://github.com/jmoiron/humanize/"
-# Tests are not included in PyPI tarballs
-# https://github.com/jmoiron/humanize/issues/33
-SRC_URI="https://github.com/jmoiron/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/mock[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- if use doc; then
- cd docs || die
- sphinx-build . _build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- esetup.py test || die "tests failed with ${EPYTHON}"
-}