summaryrefslogtreecommitdiff
path: root/dev-python/hvac/hvac-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hvac/hvac-1.2.1.ebuild')
-rw-r--r--dev-python/hvac/hvac-1.2.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/hvac/hvac-1.2.1.ebuild b/dev-python/hvac/hvac-1.2.1.ebuild
deleted file mode 100644
index 143be3d93ea6..000000000000
--- a/dev-python/hvac/hvac-1.2.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="HashiCorp Vault API client"
-HOMEPAGE="
- https://github.com/hvac/hvac/
- https://pypi.org/project/hvac/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-RDEPEND="
- >=dev-python/pyhcl-0.4.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/jwcrypto[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/semantic-version[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # ldap_test is not packaged.
- tests/integration_tests/api/auth_methods/test_ldap.py
- # https://github.com/lepture/authlib is not packaged.
- tests/integration_tests/api/auth_methods/test_oidc.py
-)