summaryrefslogtreecommitdiff
path: root/dev-python/ijson/ijson-2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ijson/ijson-2.4.ebuild')
-rw-r--r--dev-python/ijson/ijson-2.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ijson/ijson-2.4.ebuild b/dev-python/ijson/ijson-2.4.ebuild
new file mode 100644
index 000000000000..eceba6c8c743
--- /dev/null
+++ b/dev-python/ijson/ijson-2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="https://github.com/isagalaev/ijson https://pypi.org/project/ijson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi release lacks tests and git release isn't tagged yet
+# python_test() {
+# ${EPYTHON} tests.py || die
+# }