summaryrefslogtreecommitdiff
path: root/dev-python/ijson
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest2
-rw-r--r--dev-python/ijson/ijson-3.2.0_p0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index 6326b09935fc..12f4ebdfce33 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1,3 +1,5 @@
DIST ijson-3.1.4.tar.gz 125725 BLAKE2B 870439690c0b776d04c3023fb910d0f9ff2ca573be728c06802fbbbd5de1d5dcb8e677b778d30cb134d181dfc4ffd53c686af3d57458501d9548ddbdba8bf6d7 SHA512 7e64c4fec84fd6942c83809849eefc1c299c597524c0fe73e2cdc542e113faad8f35cc5219b0bc4e05842ac69d8608089d7cbb2dc006e404c184505392b21baa
+DIST ijson-3.2.0.post0.gh.tar.gz 127558 BLAKE2B 38e06039bb177c43e4744f145fed2159e317a0b8da628b85a62215cdfe6693b271c39629811513d2e563b532244950616b9105134916bc577446a0b5e5ce25f7 SHA512 b926253a3d6a070e2ac27c61542d340e4a1498de7642957dbe59e9fd3c53d700ed4e8ee71c83efcb90b2c302d15b0d268c38054c10728bbb436521aa5b42050b
EBUILD ijson-3.1.4.ebuild 578 BLAKE2B 40294a19f5c26e61f7ee2e45d5714084f4acbf142e05f5b8b98e148d7afb5b53ca0ace5de4d8319f2ed0e2e3cb5c0b1cc5d5cdd1186f272a323afabf8dd17bbb SHA512 c6473a11f7b04bf490f796aae555d7700bd9147957f1c44151a0e14ff9805e708d2c8ef64dc4e3ea5ef37e3bd26c8972c2e5132d326c6858af7a7facb702fa76
+EBUILD ijson-3.2.0_p0.ebuild 625 BLAKE2B 76c1843e8864b4c46360fc2aa6ebc80585bcc816f4d2535cee65aef1ee88765225c9643e5f4dbd7e6d6270d21c4d6879315b4dd0de90bfa395e45aba0d24a4a3 SHA512 a393b1873a298a6bf571ffb0b0f50945d4c5060ab0c3d56d1f241440ceb2f4168c75cc00d0a03853a9f97d5dfa81cd79f878aa2c8a428e49bd067bccb8754417
MISC metadata.xml 372 BLAKE2B 9fd70113a6731ca09979bacb2153df2c26db31ef9cb2a95cc2de2201aeb5348a6344fa6dab27a0880a9d70cb4498d39a4ef9cbcff6127932d5af3c534e21b5c2 SHA512 5f3747561e4c802300860b9d2f27b08acea3979e8cac48bf6145c4cbeeb3ec0b3d765399d0ed8fe01947860d78dea0faa0839cb393e066ec0aaffa2ab2661398
diff --git a/dev-python/ijson/ijson-3.2.0_p0.ebuild b/dev-python/ijson/ijson-3.2.0_p0.ebuild
new file mode 100644
index 000000000000..418b4c582e7b
--- /dev/null
+++ b/dev-python/ijson/ijson-3.2.0_p0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${P//_p/.post}"
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson/
+ https://pypi.org/project/ijson/
+"
+SRC_URI="
+ https://github.com/ICRAR/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/yajl
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest