summaryrefslogtreecommitdiff
path: root/dev-python/inflect/inflect-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/inflect/inflect-1.0.0.ebuild')
-rw-r--r--dev-python/inflect/inflect-1.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/inflect/inflect-1.0.0.ebuild b/dev-python/inflect/inflect-1.0.0.ebuild
new file mode 100644
index 000000000000..bf150255a033
--- /dev/null
+++ b/dev-python/inflect/inflect-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="https://github.com/jazzband/inflect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v tests || die "tests failed with ${EPYTHON}"
+}