summaryrefslogtreecommitdiff
path: root/dev-python/inflect/inflect-3.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/inflect/inflect-3.0.2.ebuild')
-rw-r--r--dev-python/inflect/inflect-3.0.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/inflect/inflect-3.0.2.ebuild b/dev-python/inflect/inflect-3.0.2.ebuild
new file mode 100644
index 000000000000..94231ddd4ce6
--- /dev/null
+++ b/dev-python/inflect/inflect-3.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="https://github.com/jazzband/inflect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+# nose is still required by some test features
+# https://github.com/jazzband/inflect/issues/90
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ dev-python/alabaster[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # Override pytest options to skip flake8
+ pytest -vv tests --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}