summaryrefslogtreecommitdiff
path: root/dev-python/inline-snapshot
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/inline-snapshot')
-rw-r--r--dev-python/inline-snapshot/Manifest2
-rw-r--r--dev-python/inline-snapshot/inline-snapshot-0.13.4.ebuild57
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/inline-snapshot/Manifest b/dev-python/inline-snapshot/Manifest
index 65338fa78e22..d6cd6948c019 100644
--- a/dev-python/inline-snapshot/Manifest
+++ b/dev-python/inline-snapshot/Manifest
@@ -1,5 +1,3 @@
-DIST inline_snapshot-0.13.4.tar.gz 215264 BLAKE2B 911bb7007fd35c68e0e42fb915e284394e45b7b510de875827282fc6dadf7f467a6da1efa626e9b2c348750709aea0399bcd7869dc181ab7a2121f76206404a8 SHA512 724d72984399712611c0eea5129b86b6650bdce1a4331255cf30b806ae6f03a33aa51de9f6353e84ae09ec8f6738372964f380a622481b5bf1db1e9baaa5bf00
DIST inline_snapshot-0.14.0.tar.gz 209662 BLAKE2B 9bea11df88aab049af61146cb40c8afaa7607f8812c800ee7dffc7de94403029e4ae1d1ed49921f624e5327171650210744962559786e45586ae929830f81819 SHA512 32855dcd098c3e9b6a046752a3fc03c18b0df85e2cf338a928eadcd0e63bb784bdaca6855c954974ec7561e602ff3dd95ccdadb0c4f7dd1075d9d84245c171ef
-EBUILD inline-snapshot-0.13.4.ebuild 1490 BLAKE2B 0a4f2f867af7c141a8d974f00ae57b868d173754414036784ffcb6ac7f047ca2817bea0b089993915bec153f6f3bd351bc92127f1747bd9e58776c37884040fa SHA512 d26865210d55ff182da7810286620cc4162496d6b95863777d8fc846509479741b50a682bb72e46d9a5b861b046db4f6cc9947b8a5a02bf17760cd5f80c223e7
EBUILD inline-snapshot-0.14.0.ebuild 1590 BLAKE2B f046f63ad309d440f36cd62d3d2dc711e60581645f6c8f17d1d82f4b1fc9a90108f5f92b49c04a78fb0184adf81a12588d464a6b27790d2c340081210a91ec7c SHA512 5af2fcc227fa2ffd01fa9bd2c3c9350a63fc809a559369c151c87ba08d447d0fd3f725ddd09997c468f52afa7d1269d88c7d3892bd45f65c0d5b440624776b0d
MISC metadata.xml 384 BLAKE2B 37af14f95875416431210b572e9c5e96437d773cf53174dec247a9006ad24940f17ae9803a750dd2e1e73f63675f594b326f880bf7d5cb29ff09a8aae4959e60 SHA512 173bd013e023443c9dac349fab3deea6b5e9c2f054052d3362757cc0c46dd89309c509eb6a0f5a5774a7d8acbc55578b629039615a0cb31d74001a8d0db8b680
diff --git a/dev-python/inline-snapshot/inline-snapshot-0.13.4.ebuild b/dev-python/inline-snapshot/inline-snapshot-0.13.4.ebuild
deleted file mode 100644
index e47f61d9ca17..000000000000
--- a/dev-python/inline-snapshot/inline-snapshot-0.13.4.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Create and update inline snapshots in your Python tests"
-HOMEPAGE="
- https://15r10nk.github.io/inline-snapshot/
- https://github.com/15r10nk/inline-snapshot/
- https://pypi.org/project/inline-snapshot/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/asttokens-2.0.5[${PYTHON_USEDEP}]
- >=dev-python/black-23.3.0[${PYTHON_USEDEP}]
- >=dev-python/click-8.1.4[${PYTHON_USEDEP}]
- >=dev-python/executing-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/dirty-equals-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-6.75.5[${PYTHON_USEDEP}]
- dev-python/mypy[${PYTHON_USEDEP}]
- dev-python/pydantic[${PYTHON_USEDEP}]
- >=dev-python/pytest-subtests-0.11.0[${PYTHON_USEDEP}]
- >=dev-python/time-machine-2.10.0[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires pyright
- 'tests/test_typing.py::test_typing[pyright]'
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=inline_snapshot.pytest_plugin,time_machine,pytest_subtests.plugin,xdist.plugin
- local -x PYTHONPATH=${S}/src
- epytest
-}