summaryrefslogtreecommitdiff
path: root/dev-python/ipy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/Manifest3
-rw-r--r--dev-python/ipy/ipy-1.01-r1.ebuild2
-rw-r--r--dev-python/ipy/ipy-1.01.ebuild41
3 files changed, 2 insertions, 44 deletions
diff --git a/dev-python/ipy/Manifest b/dev-python/ipy/Manifest
index 84a8bf2e1b4f..1deba342bd5c 100644
--- a/dev-python/ipy/Manifest
+++ b/dev-python/ipy/Manifest
@@ -1,4 +1,3 @@
DIST IPy-1.01.tar.gz 33641 BLAKE2B 10d5ac5c3df00a562393ee762e9ad0f458ecf4745f894ab23e686b7112842adcbb3f25064c0010630745273fa72280ba5ef92a951d687d0f46f341acd6c041ad SHA512 f0983254523025a1819d543877d9651fb6a9e39dabd3b043488495f681b02e43b544a0121658a0430a418a1c39b360a59db1699af87a75a16a2bdc29fcb2b74c
-EBUILD ipy-1.01-r1.ebuild 920 BLAKE2B 97d8c144fb5a27663898dcc0a8655974f51c9db5025a8e4439c2c0fb465561a953b837e0c12caa0b71cdc59ec0c2c10d7817acd0dded318d96870fa2681bc36b SHA512 2dbad2d996272d8148b9bcac7c81d986ae21b9ce3ee048dea020f1285717edb5f59f0d11bdad9cfd2aeac8d0032b424beca785230deb3fc3daa0da348e7c73fd
-EBUILD ipy-1.01.ebuild 1104 BLAKE2B 1a872535f4fb91fa015ae947cd0d85ff39a6047b7de82aad9f85a37702d9cc38c7001f67143da6237141ee6b0b668623b691fdf325c61146d7653ac6a4a58b40 SHA512 31e364f825961e9ce0fe0d1c69df72335f952e2b81cda5484ce3cac00a6a12b81f0bcd49bcd8109395c782d6330905c308a4d2f6e4d2bdfa165483530db206f4
+EBUILD ipy-1.01-r1.ebuild 918 BLAKE2B 024720ffcf2d41a68620d749d2d64db1ad7db910e3a5e109d990049b9a7102e7f777aaf06eae8d8bc108432ff5368ecda2fc0fca8502e57aa87df15164fb174b SHA512 f134ff9ed6a4c1e9b2e82af6bfdbe8e5b19b5d6e4843a6e480de16366010f8840cd622fcbb168f8f1bed3da0a3b559d7f7ba62109fb7005142abd44009666fae
MISC metadata.xml 404 BLAKE2B 9b453bad2b9cc6b6f7b6bca5bd69afbc1c8181f8250d5889b8a192f6a242e94b546b650d0ca05acd7668cee160642d519d2eaa3f3d8755ffa228b43efbd3a6a0 SHA512 fb2d4c33ea00c87f1106ebf2ea4150476c62acd544f9c94cf28d5113cd272179df4710595135f5edd26cded036977fb7253e77c83d34ae362bd4b35eebbe356c
diff --git a/dev-python/ipy/ipy-1.01-r1.ebuild b/dev-python/ipy/ipy-1.01-r1.ebuild
index 3557a2fbcd28..af1a4e860184 100644
--- a/dev-python/ipy/ipy-1.01-r1.ebuild
+++ b/dev-python/ipy/ipy-1.01-r1.ebuild
@@ -17,7 +17,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
IUSE="examples"
python_test() {
diff --git a/dev-python/ipy/ipy-1.01.ebuild b/dev-python/ipy/ipy-1.01.ebuild
deleted file mode 100644
index ef39a44e48bb..000000000000
--- a/dev-python/ipy/ipy-1.01.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-MY_PN="IPy"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
-HOMEPAGE="https://github.com/autocracy/python-ipy/wiki https://pypi.org/project/IPy/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
-IUSE="examples"
-
-python_test() {
- # 1 test fail under pypy, persistent from 0.82a, not a regression.
- cp -r test_doc.py README.rst test "${BUILD_DIR}" || die
- pushd "${BUILD_DIR}" > /dev/null || die
- "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
- "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}