summaryrefslogtreecommitdiff
path: root/dev-python/iso8601/iso8601-0.1.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/iso8601/iso8601-0.1.10.ebuild')
-rw-r--r--dev-python/iso8601/iso8601-0.1.10.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/iso8601/iso8601-0.1.10.ebuild b/dev-python/iso8601/iso8601-0.1.10.ebuild
new file mode 100644
index 000000000000..734d93ba8da5
--- /dev/null
+++ b/dev-python/iso8601/iso8601-0.1.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple module to parse ISO 8601 dates"
+HOMEPAGE="https://code.google.com/p/pyiso8601/ https://pypi.python.org/pypi/iso8601"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${PYTHON}" -m pytest --verbose ${PN} || die "Tests fail with ${EPYTHON}"
+}