summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-envs/jaraco-envs-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-envs/jaraco-envs-1.0.1.ebuild')
-rw-r--r--dev-python/jaraco-envs/jaraco-envs-1.0.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jaraco-envs/jaraco-envs-1.0.1.ebuild b/dev-python/jaraco-envs/jaraco-envs-1.0.1.ebuild
new file mode 100644
index 000000000000..8c85a3de844b
--- /dev/null
+++ b/dev-python/jaraco-envs/jaraco-envs-1.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7,8} pypy{,3} )
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Classes for orchestrating Python (virtual) environments."
+HOMEPAGE="https://github.com/jaraco/jaraco.envs"
+SRC_URI="https://github.com/jaraco/jaraco.envs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+
+RDEPEND="dev-python/namespace-jaraco[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' 'python3_[67]')"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# there are no actual tests, just flake8 etc
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # avoid a setuptools_scm dependency
+ sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
+ sed -r -i "s:setuptools(_|-)scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+|)[[:space:]]*::" \
+ setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
+ distutils-r1_python_install --skip-build
+}