summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-text
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest2
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.4.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index d6b0219aad66..2a2a833673d0 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.text-3.2.0.tar.gz 14279 BLAKE2B aa8c8903bac61db3d1017408e1aa525f66060422c27b754af343a64e586b64c6623b66881bea62b9b2e89821a40c933d54c9a8cddc7bda08ac108ad08a9524dc SHA512 4107ef1078b44714b6ee5fb6ebd2bb7c35415debc6eaedd8bc18a70a2936cc7c7757acd7b3fac9587201ef52a25d9b29e49f2385a0a08afffb1d0c3de6ecc377
+DIST jaraco.text-3.4.0.tar.gz 15427 BLAKE2B 4f9584b9824c4d73ac9c75bc153048466d826fb37e8240ebec12181c837bca0d8f79a3e1dce25117f4c3e361a48a1566419d2555d430fcb792b5e40eede2713b SHA512 074b963c9ccf020409a28d7ef0053d5b221f9a3b16003ca9eac663f70b1a909b4523f9e5aba606f77108723157f237602f7c9f5079a782c8bfa9fdbbb553cf28
EBUILD jaraco-text-3.2.0-r1.ebuild 1432 BLAKE2B b7e019195825f6797bd9a1e8b43c7d4ac96ff91287da0f0ddcf2a274a6ec70c6e02c88da9ed91bbec5938bee8b865a86a53b3069570c095de81f4a3454943280 SHA512 e0039d4a9db245807bc2d5b66e490bca2d98fbc7e5013d11e594be9de8c8300891b7f267797c4118a8e208b76156a6007b0260bc6159393c75e933bff57e18d1
+EBUILD jaraco-text-3.4.0.ebuild 1246 BLAKE2B f7b259a40329216ea1ae222242eb10c4840789a89bdbb705477d65d61cccf41950f28a433da8b79b6d46600515decde03021ae94d87b808f514b9780fc542193 SHA512 05599318ed2b22353ea88dc227fca9ee889e6223d3888bb70d48330cbc8febd8cc7091419ca43aa140d7c53128ec52a4aeb5d928e6cdbafeb98142119f1d1027
MISC metadata.xml 631 BLAKE2B aaa62e5e0d4cc048c1a279b16890d035cd0a60cc41e9b4c99b37876a21286248b5a00d193a2036d0c6d447ff57e635245583f571834daa5a2e994653570122b8 SHA512 84c01b2578aabd0fd5be4347ade555ca4f4ddd96e7009f7dd1b9d021465bc55f66431c72ed05a7e5633a81f3b401f8f77568bacc872198e145b5421aed05491e
diff --git a/dev-python/jaraco-text/jaraco-text-3.4.0.ebuild b/dev-python/jaraco-text/jaraco-text-3.4.0.ebuild
new file mode 100644
index 000000000000..175555df272f
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.text"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_6)
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+python_test() {
+ # Override pytest options to skip flake8
+ PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
+python_install() {
+ rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
+ distutils-r1_python_install
+}