summaryrefslogtreecommitdiff
path: root/dev-python/jedi/jedi-0.17.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jedi/jedi-0.17.0.ebuild')
-rw-r--r--dev-python/jedi/jedi-0.17.0.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/jedi/jedi-0.17.0.ebuild b/dev-python/jedi/jedi-0.17.0.ebuild
index ec64254f90cb..e8e830ee68ec 100644
--- a/dev-python/jedi/jedi-0.17.0.ebuild
+++ b/dev-python/jedi/jedi-0.17.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -25,7 +25,8 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
RDEPEND=">=dev-python/parso-0.5.2[${PYTHON_USEDEP}]"
-distutils_enable_sphinx docs
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
distutils_enable_tests pytest
python_prepare_all() {
@@ -54,9 +55,12 @@ python_prepare_all() {
sed -e '/with sqlite3\.connect/,+2d' \
-i test/completion/stdlib.py || die
- # really silly assumptions, not fit for py3.8
- sed -e '/len(difference)/s:20:22:' \
+ # really silly assumptions, not fit for py3.8/3.9
+ sed -e '/len(difference)/s:20:27:' \
-i test/test_utils.py || die
+ # py3.9
+ sed -e 's:test_infer_on_generator:_&:' \
+ -i test/test_api/test_api.py || die
# tests relying on pristine virtualenv
# this relies on test* not matching anything else