summaryrefslogtreecommitdiff
path: root/dev-python/jenkins-webapi
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jenkins-webapi')
-rw-r--r--dev-python/jenkins-webapi/Manifest4
-rw-r--r--dev-python/jenkins-webapi/jenkins-webapi-0.5.0.ebuild59
-rw-r--r--dev-python/jenkins-webapi/metadata.xml8
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/jenkins-webapi/Manifest b/dev-python/jenkins-webapi/Manifest
new file mode 100644
index 000000000000..da35d25d9609
--- /dev/null
+++ b/dev-python/jenkins-webapi/Manifest
@@ -0,0 +1,4 @@
+DIST jenkins-1.596.3.war 68396864 BLAKE2B e391ffd919544f49570ba5bf76d61c91155f193e575b5ff11870153d9bdc3f997560f41de00dda8d1ffec5c5fec544c187442e8a5ff64d249dd8277257339641 SHA512 8652d4d18e3258208fe190c4a6aa5586faa66f690d7d7f7369c5490a587e3ec5e074dc22f2c8caedf5e5335f5b8f511717b2d6eb667a61e9948a703bf80310fe
+DIST jenkins-webapi-0.5.0.tar.gz 78813 BLAKE2B 0d017fd05a60bcc5d1333215e97c2d2ade658384d75a3dbb41c84e286d2b4c86d8383b28ba75e05b7f1ac5d153a46cb3c165cea063993f7aace79566dd25b4d9 SHA512 dde91231e6fe6713eb5953efa038d44a820b51968c2b0591e5dd064c7a35c7dab4d1780370dc97a0a671b3d3cb7d8a48e571c7c0af4f0d5f8a65430c8c074eb3
+EBUILD jenkins-webapi-0.5.0.ebuild 1561 BLAKE2B 0e6d68b7abcfe2f10ea49ff4c9acc6ecb1e05d9106095a3031ddbfb9ae33991a4354c6a2d5aca3ffd95db75dc819731134e0300b0b12c7699b5f7defdcb9749e SHA512 0f161b5bee11e27c546248db1ac75ad4d0abf687e6446764a65b049179c90d71c74e2a2f4b6098eee8749ee78f87a29cb6edc10ea929fd5f215ada77f120bc6f
+MISC metadata.xml 254 BLAKE2B 05f96be874d2a68967067703e58712096952aa8dca36bce98d4149440712ee7901eaa71761dcfead7fec125b4133098da92854d91531925e7a205fca0bfef368 SHA512 2e112d5670c712a9738320e0505f1758f82d57ddcb2bc71e3ad22ee08ef52538f150c316571e59cc3a86f3647cf3ebefe715762c79048e9a2ea56e1a6245ee77
diff --git a/dev-python/jenkins-webapi/jenkins-webapi-0.5.0.ebuild b/dev-python/jenkins-webapi/jenkins-webapi-0.5.0.ebuild
new file mode 100644
index 000000000000..b918a072d7ea
--- /dev/null
+++ b/dev-python/jenkins-webapi/jenkins-webapi-0.5.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+JENKINS_VERSION="1.596.3"
+
+DESCRIPTION="Module for interacting with the Jenkins CI server"
+HOMEPAGE="https://github.com/gvalkov/jenkins-webapi"
+SRC_URI="https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( http://mirrors.jenkins-ci.org/war-stable/${JENKINS_VERSION}/jenkins.war -> jenkins-${JENKINS_VERSION}.war )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/requests-2.7.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ net-analyzer/netcat
+ net-misc/curl
+ app-arch/unzip
+ >=virtual/jre-1.7.0
+ >=dev-python/pytest-2.6.3[${PYTHON_USEDEP}]
+ >=dev-python/termcolor-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/httmock-1.2.2[${PYTHON_USEDEP}] )
+ doc? (
+ >=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/alabaster-0.6.1[${PYTHON_USEDEP}] )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ if use test; then
+ # tests fail with jenkins 1.6x
+ # https://github.com/gvalkov/jenkins-webapi/issues/14
+ mkdir -p "${P}/tests/tmp/latest"
+ cp "${DISTDIR}/jenkins-${JENKINS_VERSION}.war" "${P}/tests/tmp/latest/jenkins.war"
+ fi
+}
+
+python_test() {
+ emake test
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jenkins-webapi/metadata.xml b/dev-python/jenkins-webapi/metadata.xml
new file mode 100644
index 000000000000..773d698964bf
--- /dev/null
+++ b/dev-python/jenkins-webapi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">gvalkov/jenkins-webapi</remote-id>
+ </upstream>
+</pkgmetadata>