summaryrefslogtreecommitdiff
path: root/dev-python/json-rpc/json-rpc-1.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/json-rpc/json-rpc-1.10.1.ebuild')
-rw-r--r--dev-python/json-rpc/json-rpc-1.10.1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/json-rpc/json-rpc-1.10.1.ebuild b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
deleted file mode 100644
index 857752944190..000000000000
--- a/dev-python/json-rpc/json-rpc-1.10.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="JSON-RPC transport implementation for python"
-HOMEPAGE="https://github.com/pavlov99/json-rpc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- cat > jsonrpc/six.py <<- EOF
- from __future__ import absolute_import
- from six import *
- EOF
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}