summaryrefslogtreecommitdiff
path: root/dev-python/json-rpc/json-rpc-1.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/json-rpc/json-rpc-1.13.0.ebuild')
-rw-r--r--dev-python/json-rpc/json-rpc-1.13.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/json-rpc/json-rpc-1.13.0.ebuild b/dev-python/json-rpc/json-rpc-1.13.0.ebuild
new file mode 100644
index 000000000000..8c3617e47010
--- /dev/null
+++ b/dev-python/json-rpc/json-rpc-1.13.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON-RPC transport implementation for python"
+HOMEPAGE="https://github.com/pavlov99/json-rpc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+BDEPEND="${RDEPEND}
+ test? ( dev-python/flask[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest