summaryrefslogtreecommitdiff
path: root/dev-python/json-rpc/json-rpc-1.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/json-rpc/json-rpc-1.14.0.ebuild')
-rw-r--r--dev-python/json-rpc/json-rpc-1.14.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/json-rpc/json-rpc-1.14.0.ebuild b/dev-python/json-rpc/json-rpc-1.14.0.ebuild
deleted file mode 100644
index c150dde004ab..000000000000
--- a/dev-python/json-rpc/json-rpc-1.14.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="JSON-RPC transport implementation for python"
-HOMEPAGE="
- https://github.com/pavlov99/json-rpc/
- https://pypi.org/project/json-rpc/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/flask[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
- # bundled, sigh.
- rm jsonrpc/six.py || die
- sed -i -e 's:from . import six:import six:' jsonrpc/*.py || die
-}