summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-client
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter-client')
-rw-r--r--dev-python/jupyter-client/Manifest7
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.0.3.ebuild49
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.1.0.ebuild49
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.2.0.ebuild49
-rw-r--r--dev-python/jupyter-client/metadata.xml23
5 files changed, 177 insertions, 0 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
new file mode 100644
index 000000000000..c7e4ab8badbd
--- /dev/null
+++ b/dev-python/jupyter-client/Manifest
@@ -0,0 +1,7 @@
+DIST jupyter_client-8.0.3.tar.gz 334366 BLAKE2B 04ea6e8206fe0b741da1ba0d17cb559657824c20f4fcff48fd0ce4287dce7da9a151000e7a0f08cbf3fa6b1868d8d7e424d49d70a258283466350946f4ce5220 SHA512 27eca49e44c13d819624c6ab596b24b9b469f82a788920eb4db02cee43c2efdf22ea68bf282f5f4ca28d38c9238d51d70d7aa214f2c3b8f6c2a7ebcaf12d567c
+DIST jupyter_client-8.1.0.tar.gz 335241 BLAKE2B d9491f958b21ba09494bf42ff5a3bae786388a16c007f5756df8900fc53c6fdb4d67bff09b16290338d07fc3c3466483f20ab82482fb235e0e55481294eaeef1 SHA512 21317e5ca61b72408e94116f0be545753088d891742579fcf7a451be179a7783dc153d2898e0ff50ce06017f90cb48f907a5bb056090b13ec0da2af7287f6dcd
+DIST jupyter_client-8.2.0.tar.gz 335567 BLAKE2B e02f8813d12ec8ba0e15291dad04cfaeeb98ea524050a10d142d74af203e43aa1c2e22e7fd7b071c05831b3dd644985a42e38f59fee65f4570e5eb88bbc9fbb1 SHA512 1337c4f2d93d9cd2ae5e3d8f30a8e4af69dad6e09c97e949d9300df0668be4da91134c73da06eb417c10ff2c09fd7beb28699e7a17502ceee3453cb9323b4363
+EBUILD jupyter-client-8.0.3.ebuild 1295 BLAKE2B 11c3b7bf39626ebb65e8933ddda228a64e4f559195676ab34c34d42094fa55b4ed2be88b59809f7a0d54412716cf25496d8bc3d6a6815e3d154fb1ec79e5a2ef SHA512 c927b5cc9d3a9ae91561dac5467d2fb06ddc03dc6dea77d524a76edbd2d063e6a092ca404b6a3b418a4c9870729163e569b22458d7dfc88f95a48e76c03056a4
+EBUILD jupyter-client-8.1.0.ebuild 1303 BLAKE2B 7eb1fa187f769e9ca218d61ce76d7faa575ef5d97a125daa3a1fb7aa6e96d14bc74d7dd46a1aa862722419268aaf020d3487dd466b2fc2e9e1209582cca443a5 SHA512 c9840f9901034f2876b3c44d15499ae0d6604d15df56a50391f0aadceed752d38a725fe7b6146d5f8bb55a384c147ee655a42b0c2304956e3911b0bffdf22ed5
+EBUILD jupyter-client-8.2.0.ebuild 1309 BLAKE2B f5b40330b3ce615fca940d64d0bab1117adde14bd361b4bce56c35eac7536d80a7025772f2add8fec2b8222b11003b6c056718153653292c03ff017b451e0bcc SHA512 7293217b0bac1fb14eb3ce7086cda37b857348ae097cb0e7725cdcca05512b6bdc9bfa2c89978c77db088496bff81064ec8f68dec6e5bc10b49dcab19c211f37
+MISC metadata.xml 844 BLAKE2B 8beea01f144f8e28b58b1bd4d0d2a32eda4b5e50e479c83ed940cd6894d581aa22418bc2733910465cb6980134c3a29b63a6e31f595d037b9492337285837ac6 SHA512 73f427cc561e728c6f941052a4b6f9c6ec5c9d6ba3bb601bc58313687dfc8d6ed3602e1fb2f7f0ea00aec4360c8c1200334675917d22092ed79585b117865ebd
diff --git a/dev-python/jupyter-client/jupyter-client-8.0.3.ebuild b/dev-python/jupyter-client/jupyter-client-8.0.3.ebuild
new file mode 100644
index 000000000000..5b8619ab0d01
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)
diff --git a/dev-python/jupyter-client/jupyter-client-8.1.0.ebuild b/dev-python/jupyter-client/jupyter-client-8.1.0.ebuild
new file mode 100644
index 000000000000..503ce6564a01
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)
diff --git a/dev-python/jupyter-client/jupyter-client-8.2.0.ebuild b/dev-python/jupyter-client/jupyter-client-8.2.0.ebuild
new file mode 100644
index 000000000000..f94d688c0313
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)
diff --git a/dev-python/jupyter-client/metadata.xml b/dev-python/jupyter-client/metadata.xml
new file mode 100644
index 000000000000..a41692a7eeae
--- /dev/null
+++ b/dev-python/jupyter-client/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ Contains the reference implementation of the Jupyter protocol. It
+ also provides client and kernel management APIs for working with
+ kernels. It also provides the jupyter kernelspec entrypoint for
+ installing kernelspecs for use with Jupyter frontends.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">jupyter/jupyter_client</remote-id>
+ <remote-id type="pypi">jupyter-client</remote-id>
+ </upstream>
+</pkgmetadata>