summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-ydoc
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter-ydoc')
-rw-r--r--dev-python/jupyter-ydoc/Manifest4
-rw-r--r--dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.2-no-node-for-version.patch30
-rw-r--r--dev-python/jupyter-ydoc/jupyter-ydoc-2.0.1.ebuild48
-rw-r--r--dev-python/jupyter-ydoc/metadata.xml13
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/jupyter-ydoc/Manifest b/dev-python/jupyter-ydoc/Manifest
new file mode 100644
index 000000000000..af40bb60f1d4
--- /dev/null
+++ b/dev-python/jupyter-ydoc/Manifest
@@ -0,0 +1,4 @@
+AUX jupyter-ydoc-1.0.2-no-node-for-version.patch 846 BLAKE2B 030e4ee6af5c8f6392261264996dfd4a44794d387db152fb396d1a8dc0fe5fe3612f7d37cef40076f55934a026ca2d54c9a5690775aeef2b412d37395e253c96 SHA512 8798924fed0e5e47c1acf7e7c40bd532a154d0084d7684d57764ca00df87155edc4223506ebcbf71df37a39c1252613ac31f9351105f8515121bf5668091e1cf
+DIST jupyter_ydoc-2.0.1.gh.tar.gz 984325 BLAKE2B bd15590f7eb9865304ae51931a8bb5a730959b1231a4c538b350c5d41f9891386158b18a75a744fff379edf2deea557d8fd26e5de6fcef7dddb39055e57fc883 SHA512 cd4c78f98578e349e18ca7d51b57cdd281f4e092c24bd152138c06158b484b9de2b44e37e43bbca55055575a37ecae7fc7c7032a0ca4bcd874abf15b815ad5d2
+EBUILD jupyter-ydoc-2.0.1.ebuild 1094 BLAKE2B 88bb06d8d490183cfdff43cbb0b65d432861b8e6ef296579cebfc4e5e81ce22bc82382030a9b0e34a79ef0973b15af2f3643775deb4236060ba09abfb49df648 SHA512 bb28adea1fdb7a52178ffc8ed694fbb04b796ac9168eb0f15f39c53b9b889739082d20d036e6e0bd51ac2a0dbff92491662c6a4d1e9b66fa94130ae438446131
+MISC metadata.xml 433 BLAKE2B cf2579c7d85eefe97d8ec81f37ac5e10deee9aaf52b16cea8ce3649f6076a3afee9e7ce6efbf82cd7713421353b53c16ed4d28b03a9b6e8b5c029fc6f3615651 SHA512 1258a3f0bd2a959055312594eb72bcd06fd639cf777543b41919da60b4082d241ad87231bdfb8c2ef057c85657875ac596b732301d3fb0c9a10cea5d2746234f
diff --git a/dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.2-no-node-for-version.patch b/dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.2-no-node-for-version.patch
new file mode 100644
index 000000000000..bfd138ce0d66
--- /dev/null
+++ b/dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.2-no-node-for-version.patch
@@ -0,0 +1,30 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 6e0a069..42f76c1 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -2,12 +2,12 @@
+ # Distributed under the terms of the Modified BSD License.
+
+ [build-system]
+-requires = ["hatchling>=1.10.0", "hatch-nodejs-version"]
++requires = ["hatchling>=1.10.0"]
+ build-backend = "hatchling.build"
+
+ [project]
+ name = "jupyter-ydoc"
+-dynamic = ["version"]
++version = "1.0.2"
+ description = "Document structures for collaborative editing using Ypy"
+ requires-python = ">=3.7"
+ keywords = ["jupyter", "ypy"]
+@@ -56,10 +56,6 @@ text = "BSD 3-Clause License"
+ Homepage = "https://jupyter.org"
+ Source = "https://github.com/jupyter-server/jupyter_ydoc"
+
+-[tool.hatch.version]
+-source = "nodejs"
+-path = "javascript/package.json"
+-
+ [tool.hatch.build]
+ exclude = ["javascript", "!javascript/package.json"]
+
diff --git a/dev-python/jupyter-ydoc/jupyter-ydoc-2.0.1.ebuild b/dev-python/jupyter-ydoc/jupyter-ydoc-2.0.1.ebuild
new file mode 100644
index 000000000000..a30ad14c4ca9
--- /dev/null
+++ b/dev-python/jupyter-ydoc/jupyter-ydoc-2.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Document structures for collaborative editing using Ypy"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_ydoc/
+ https://pypi.org/project/jupyter-ydoc/
+"
+SRC_URI="
+ https://github.com/jupyter-server/jupyter_ydoc/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Requires node
+RESTRICT="test"
+
+RDEPEND="dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ dev-python/pycrdt[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.0[${PYTHON_USEDEP}]
+ dev-python/pycrdt-websocket[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.2-no-node-for-version.patch"
+)
+
+distutils_enable_tests pytest
+# Hangs for some reason
+#distutils_enable_sphinx docs/source dev-python/myst-parser dev-python/pydata-sphinx-theme
diff --git a/dev-python/jupyter-ydoc/metadata.xml b/dev-python/jupyter-ydoc/metadata.xml
new file mode 100644
index 000000000000..a7e33c55e1cf
--- /dev/null
+++ b/dev-python/jupyter-ydoc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyter-ydoc</remote-id>
+ <remote-id type="github">jupyter-server/jupyter_ydoc</remote-id>
+ </upstream>
+</pkgmetadata>