summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_core/jupyter_core-4.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter_core/jupyter_core-4.4.0.ebuild')
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.4.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/jupyter_core/jupyter_core-4.4.0.ebuild b/dev-python/jupyter_core/jupyter_core-4.4.0.ebuild
index a2804624d23b..962e95ed8c62 100644
--- a/dev-python/jupyter_core/jupyter_core-4.4.0.ebuild
+++ b/dev-python/jupyter_core/jupyter_core-4.4.0.ebuild
@@ -18,7 +18,7 @@ IUSE="doc test"
RDEPEND="
dev-python/traitlets[${PYTHON_USEDEP}]
- "
+"
DEPEND="${RDEPEND}
!!<dev-python/jupyter-1.0.0-r1
doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
@@ -28,7 +28,10 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
>=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
)
- "
+"
+
+# tests require installation of jupyter_core, bug #649538
+RESTRICT="test"
python_prepare_all() {
# Prevent un-needed download during build